Editor - Could not clip any features

857
3
08-10-2017 05:24 PM
Highlighted
New Contributor

Hi there,

 

We have recently upgraded to 10.4 desktop and have been experiencing some issues with the clip function whilst editing.

We've been getting the Error "Could not clip any features. There are no features coincident with the selected feature".

A few things of note. We are using SDE databases and this seems to be happening just when using the freehand draw tool. So I've drawn the same polygon to clip (discarding the area that intersects) using the normal polygon option and it will work. But when using the freehand tool to draw the feature, it will come up with this error.

I have tried exporting the features into shapefiles and geodatabases to test and they work fine there when using the freehand tool (though I didn't export the entire database so I'm not sure if it's a matter of too many features/vertices or similar).

Just hoping to find out if anyone has come across similar or might know of a solution? Unfortunately, our workflow heavily depends on using the freehand tool to digitise many polygons. We are unable to revert to the polygon option due to time constraints.

 

Thanks heaps

Reply
0 Kudos
3 Replies
Highlighted
Honored Contributor

Ensure to save the edits before applying Clip function (Editor). The clip might might not occur if you select an unsaved feature.

Reply
0 Kudos
Highlighted
New Contributor

Thanks for the suggestion Jayanta. Unfortunately we have tried that and it still doesn't work. We've tried saving, then completely stopped editing as well to make sure the save has worked. It's a bit odd that it doesn't think there' a feature there.

Reply
0 Kudos
Highlighted
New Contributor II

I had the same problem in gdb. I exported the feature from the gdb to shape file and it worked. Not a real solution, but at least functioned for me.