Editing sessions are saving automatically

06-26-2014 05:42 AM
New Contributor
I have recently upgraded to version 10.2.2.  My company works in an SDE environment because we have several users that do editing.  Anyway, since upgrading, whenever I perform an edit and then click "stop editing", I'm not getting the prompt to save my edits.  Also, if I click undo after an edit, it does not recognize what I have done, and just removes the layer from the map, but keeps the edit that I was trying to undo.  I have searched everywhere I could think of to see if anyone else has had this happen, but I haven't had any luck

If I am working in a normal File Geodatabase, I get the prompts to save and everything seems to be working fine.  It's just happening in the SDE.  I'm kind of worried about it because several people edit these feature classes, and I feel as though things have the potential to really get messed up.  I have attached the settings that I have in the Editing options box.

Thanks in advance for any help that can be provided.

Dana Bissey

Tags (2)
0 Kudos
1 Reply
Occasional Contributor III
I think this may still be a bug.  The information in quotes below was taken from:


I have figured out the problem, but am waiting for a permanent solution from ESRI support. It appears that ArcGIS 10.2.1 introduced a new option: Editor > Options > Versioning > Automatically save changes after each edit which is checked by default and must be manually unchecked each time you open a map - unchecking the option works for the current map/session, but the next time you open a new or existing map it's checked again. The slow performance is caused by the editor writing to the database and committing and saving each attribute/feature edit to the database one at a time after each edit - normally you only do this once when you save changes at the end of each edit session.

FYI - this issue has been logged by ESRI as a 10.2.1 bug:

[#NIM098991 The option to "Automatically save changes after each edit" within the "Editing Options" does not stay unchecked after the Map Document is saved]. For updates on this issue, you can go to ESRI's Customer Care Portal site.

At this point, there is no workaround for this issue. You will have to ensure that your users uncheck the option to "Automatically save changes after each edit" each time they open the Map Document.


Looks like it is scheduled to be fixed with version 10.3

0 Kudos