Database connection does not exist or is not supported, when creating any rastertype

712
9
07-07-2010 08:58 AM
Highlighted
New Contributor
environment : ArcInfo 10 - ArcSDE 10 64bit - SQL2008 R2 64bit - Win 7 Pro 64bit
[ATTACH=CONFIG]1606[/ATTACH]
Below is the message from trying to create a empty raster mosaic. I can create point, poly, and table type layers.

Messages
Executing: CreateMosaicDataset "Database Connections\ogdbismarck43_EdnSDE.sde" test "GEOGCS['GCS_North_American_1927',DATUM['D_North_American_1927',SPHEROID['Clarke_1866',6378206.4,294.9786982]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]];-400 -400 1000000000;-100000 10000;-100000 10000;8.98305509728916E-09;0.001;0.001;IsHighPrecision" # #
Start Time: Wed Jul 07 11:13:16 2010
ERROR 000622: Failed to execute (CreateMosaicDataset). Parameters are not valid.
ERROR 000732: Output Location: Dataset Database Connections\ogdbismarck43_EdnSDE.sde does not exist or is not supported
...
Failed to execute (CreateMosaicDataset).
Failed at Wed Jul 07 11:13:16 2010 (Elapsed Time: 0.00 seconds)

any type of raster gives the same error. the connection is good and i can create other layers just not raster mosaics.

any suggestions or things to check would be great.
thanks
njkirby
Reply
0 Kudos
9 Replies
Highlighted
Occasional Contributor
Hi njkirby,

We have a few questions about your issue. 
- Can you create a "raster dataset" or "raster catalog"?  Or is it just the mosaic dataset that is not being created?
- Are there any errors in the SDE error log? 
- Did you change the ArcSDE DBTune raster_storage parameter?


Simon W.
Reply
0 Kudos
Highlighted
New Contributor
Simon

1. i get the same error message when i try and create a raster dataset or raster catalog.
2. no errors in the log.
3. default install - used the default settings for the dbtune, no changes where made.

thanks
nathan
Reply
0 Kudos
Highlighted
Occasional Contributor
Thank you for the quick response Nathan.

We are going to take you exact Desktop-OS-SDE configuration and try to reproduce this in-house. 

However for immediate attention, you will probably want to contact Support.  This allows ESRI to log your incident, contact you for additional information, and even trace what is going on within your system.  The toll free number for Support is 1-888-377-4575.


Thanks,
Simon W.
Reply
0 Kudos
Highlighted
Occasional Contributor
We have tried this test with SQL Server 2008 R2, and we still create a mosaic dataset\raster dataset\raster catalog.  The only thing we can think of is that it may be some sort of configuration issue.  I hope that you have already contact Support about this issue. We will probably need to look at this more in-depth.


Thanks,
Simon W.
Reply
0 Kudos
Highlighted
Occasional Contributor
Did you ever get a resolution on this?  I'm having the exact same problem...
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
1.  Can you try creating the mosaic dataset as a different user other DBO?  For example, create a user called 'test' in SQL Server Management Studio and grant the following permissions:

CONNECT
CREATE TABLE
CREATE FUNCTION
CREATE PROCEDURE

http://resources.arcgis.com/content/kbase?fa=articleShow&d=34639

Connect as the 'test' user in ArcCatalog and try to create the mosaic dataset.

2.  Was this database upgraded from a previous version of SQL Server?  If so, check to make sure the compatibility level is set to 100 by opening SQL Server Management Studio > right-click on database > Properties > Options.
Reply
0 Kudos
Highlighted
Regular Contributor III
Hi all,

I have never experienced this on my own, but I've heard from others that copying the .sde connection file (.sde file that is stored in user folder, i.e., documents and settings on XP / Users on Win7) to another folder, which will be easily accessible (for example, C:\GISData) and will not contain spaces, might help.
Reply
0 Kudos
Highlighted
New Contributor
Nathan Kirby - I am encountering the same issue.

Did you - or anyone else - ever resolve this problem?
Reply
0 Kudos
Highlighted
New Contributor
Found out what was causing my problem.

It pre-dates my time here but in order to minimise the size of the DB backup, the raster filegroup was set to read-only within our environment. This was preventing any kind of raster data upload from succeeding.

Discovered by consulting the dbo.sde_dbtune table and properties of the database (SS Management Studio>Right-click  on DB>Properties>Filegroups)
Reply
0 Kudos