Corrupt Featureclass

687
3
06-04-2014 09:35 AM
EdDempsey
New Contributor III
I have a point featureclass in a 10.1 file geodatabase.   The featureclass table contains over 17,000 records yet when I now zoom to full extent only about 60 of the points display.  If you zoom to a different area most points will show up, but it seems very inconsistant.  

To fix this issue I have tried the following:
- I deleted and rebuilt the spatial index.
- I tried importing the featureclass to a blank geodatabase; only 58 records showed up.
- I tried to export to new featureclass; this errors out.
- Issued the Repair Geometry command �?? no change.
- I even added x, y fields to the table, calculated the Geometry for x,y, and tried to export to DBF thinking I could then add the t        able back in as x,y data�?� only 58 records show up.

Clearly something is corrupt, does anyone have an idea on what I could try next?
0 Kudos
3 Replies
VinceAngelo
Esri Esteemed Contributor
That does indeed sound like a corrupt FGDB.  Unfortunately, the only sure-fire
solution is go to your backup archive from a time before the directory contents
were corrupted.  You can contact Tech Support, but recovering corrupt data
in this context is unlikely.

- V
0 Kudos
shuang013
New Contributor III

Hi there,

I just want to follow up on this issue again since we were dealing with it recently. What we did to  apparently resolve the issue is to simply pull a backup archive from a time before and update the spatial index, The issue does not seem to occur anymore

Based on this, my question here is can spatial index potentially corrupt the feature class within the FGDB if not updated accordingly?

I was reading the suggestion below on when to update the spatial index and it states that re-creation of the spatial index is recommended only after you have added a large number of feature that differ in size from the features that are already in the feature class. This applies to adding features in edit sessions only. 

(An overview of spatial indexes in the geodatabase—ArcGIS Help | ArcGIS Desktop

 thanks

Thanks

0 Kudos
VinceAngelo
Esri Esteemed Contributor

ANY write operation, if it fails, can corrupt a file geodatabase. Actual media failure is more likely the cause, especially when the FGDB is on a networked device.

The instruction to rebuild the index after a high volume of inserts is more likely to prevent fragmentation in the index, not related to corruption.

- V

0 Kudos