Coordinates or Measures are out of bounds Why?

01-12-2017 12:36 PM
New Contributor II

When I try to copy an annotation I get an error message say Coordinates or Measures are out of bounds.

11 Replies
MVP Legendary Contributor

That error appears in several places and generally it is associated with

Error: The coordinates or measures are out of bounds 

in your case, when copying annotations.

other examples

Common errors that may occur during editing—Help | ArcGIS Desktop 

New Contributor II

Thanks Dan, I will follow up on your suggestions. 


0 Kudos
Occasional Contributor III

Others having a similar issue may find that the message about the coordinates or measures being out of bounds is incorrect. I attempted increasing the XY extent well beyond the project extent but still received the same error message. New annotation can be created in the layer. Attempting to move the annotation causes the error message to show up. I did edit the related polygon feature class prior to editing the annotation feature class so perhaps this is related to the issue.

This is with version 10.2.2.

0 Kudos
Occasional Contributor II

This is exactly what I am experiencing today. Did you have a solution? Thanks!

0 Kudos
Esri Contributor

While exporting CAD polyline features to Geodatabase I have faced the same issue "Coordinates or measures are out of bounds". In my case it is because of wrong Elevation value.

To resolve this while exporting in the Environments change Z values from same as input to Disable. Its worked well.

New Contributor II

I tried this but it still returned the error:

ERROR 000016: 1 annotation(s) rejected
The coordinates or measures are out of bounds.

It also has a new warning that didn't appear before I made this change:

WARNING 000597: Failed to insert input record with FeatureID 1.
WARNING 000595: C:\Users\wwaters\AppData\Local\Temp\250\arcA663\MultiPatch0.fid contains the full list of features not able to be copied.
WARNING 000597: Failed to insert input record with FeatureID 2.
WARNING 000597: Failed to insert input record with FeatureID 3.
WARNING 000597: Failed to insert input record with FeatureID 4.

...etc for 500 records.

ArcGIS 10.5

0 Kudos
New Contributor

@ TT

  I was getting this error after converting my labels to annotation because I wanted to move them around. After exporting them and trying to edit the location of the annotation, I would get the error message and it was impossible to move the text. I dicovered that if I use the "Edit Annotation features" tool instead of the "Move" tool, it would allow me to move the exported annotation feature. You do have to set a reference scale prior to exporting to annotation if you are exporting them from the Map view, so be aware of that. Also, when exporting annotation you will need to check the box for "Convert unplaced labels to unplaced annotation". This worked for me really well and I found that I could edit the location and the attributes of the annotation once exported. Hope this helps.


0 Kudos
New Contributor III

This resolves it for one of my feature layers (Point) but my other (Line) is still throwing the error...😕

0 Kudos
MVP Regular Contributor

I was receiving this error when copying and pasting data.........


a feature class with spatial records in only a geographic coordinate system (GCS) (wkid 4326) with NO projected coordinate system (PCS) assigned:


a feature class that did have PCS wkid 3857 assigned, along with GCS wkid 4326.

paste features failed the coordinates or measures are out of bounds‍


First, I took a backup of the FROM FC by exporting to a file gdb.


I tried Defining a PCS of wkid 3857 to the FROM FC using the 'Define Projection' GP Tool.

Didn't work


I tried removing m and z values.

Didn't work


Then I recalculated the extent.

Didn't work.


Then I imported extent from a feature class with a bigger extent in which the copy and paste worked.

Tried the copy and paste, and didn't work.

My guess as to why redefining the extent was not working is because the existing Domain, Resolution, and Tolerance xy values were already too restricting, and did not allow a fc with only a GCS in decimal degrees with its' broad extent to fit into its' extent.

As the Esri doc says, you can modify the extent, but it still must be smaller than the Domain bounding box. 


I created a file gdb fc with PCS wkid 3857, with GCS wkid 4326, and created six points at the extremities of the 'imagery hybrid' Esri basemap.

I figured that then, I could import this extent into the FROM feature class, since I made the data so spread out.

Didn't work.


The only solution I had was to delete the FC that experienced this issue, and make a brand new feature class with the correct PCS (wkid 3857 in my case), which also included the GCS of wkid 4326 with it.

Then, try to copy and paste on the blank fc.

Now the copy/paste worked.

0 Kudos