Coded Value Domains

2460
3
05-26-2015 01:10 PM
Highlighted
New Contributor

Hello,

I have a File Geodatabase that has many fields in it.  Some of these fields have coded domain values.  This has been working perfectly for months.  I just added an additional code for a specific domain, and now none of the coded values work.  It used to have the dropdown menu options for the fields that had coded values and now when I am in an edit session - there is not a dropdown menu, instead it it just allowing me to type regularly.  I have tried to delete the last coded value to see if that would work - it did not.  I have tried all the logical things (like restarting ArcMap, ArcCatalog, etc.).  Has anyone had this issue?  If so, how did you fix it?


Thank you!!

Sandy Smith

Reply
0 Kudos
3 Replies
Highlighted
MVP Honored Contributor

Please note that the GeoNet Help​ space is for the discussion of the working of GeoNet, not about specific applications. I'll move this to Managing Data​, but please move it to a more appropriate space if necessary.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Another logical thing to try is to review the FGDB Database properties to make sure it still see it there.  It would be goo to check the domain Name, and coded values.  Then look at the field properties and make sure it is still assigned correctly.  There is nothing in what you said that would indicate that there is a problem with either, but never hurts to check.  Never hurts to check the basics, just to rule it out.

Just fyi:

I have a script that runs periodically that recreates many of my layers and reassigns all the domains.  This may be overkill, but I figure that way if I change something, i force it to be updated.  I have many fairly complicated domains in my master.

I have all my domain files stored in a FGDB, then run thru a few loops using the command

arcpy.TableToDomain_management

Reply
0 Kudos
Highlighted
Esri Contributor

Do you by chance have subtypes on the feature class?

If subtypes exist, can you review if domains have been assigned on the subtype level?

Review the "Creating subtypes and associating default values and domains" section for an example.

If the above information is not applicable, can you create a new file geodatabase and export a single feature as a new feature class > test the domain usage in ArcMap to determine if the same behavior can be reproduced.

You can subsequently zip this sample file geodatabase and attach it here for review.

Thanks

Reply
0 Kudos