clip data management

1020
10
Jump to solution
11-08-2016 08:36 PM
Highlighted
New Contributor III

Hello people, I am trying to #clip raster by polygon to determine the area of the raster image within the shapefile area using ArcGIS 10.2.2. But the clipping is failing. I am using the Clip (Data Management) tool. Both the raster image and the shapefile polygon is in BTM (Bangladesh Transverse Mercator) projection system. I am keeping the "Use input features for clipping geometry" box checked and "Maintain clipping extent" box unchecked. I followed the same procedure for 15 other files which worked out fine. I am attaching the raster image and the shapefile hereby. I would be obliged if someone could help me over here. Thanks in advance.

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Honored Contributor

Close all ArcGIS Desktop applications. Open a new/blank ArcMap session.

Add the raster and polygon to the AcMap.

Run the tool (Also save the output Raster to a smaller pathname, not in the default.gdb; Also NO space and use underscore instead of any special character)

e.g. D:\Project\Data_2011.gdb\Jamuna_2011

View solution in original post

10 Replies
Highlighted
MVP Esteemed Contributor

in 10.4 the extent is now expected to be rectangular Clip—Help | ArcGIS for Desktop 

why not try the equivalent in Clip—Help | ArcGIS for Desktop 

Reply
0 Kudos
Highlighted
New Contributor III

Right now 10.4 version is not available for me. Is there any other way to do it in version 10.2.2?

Reply
0 Kudos
Highlighted
Honored Contributor

I am able to clip the Raster using Clip (Data Management). Turn off the Background processing (Geoprocessing > Geoprocessing Options) and try again.

Here is what I got

Reply
0 Kudos
Highlighted
New Contributor III

Thanks for you reply. Your output is exactly what I need, but it is failing even after turning off the background processing. The error message is like this-

Reply
0 Kudos
Highlighted
Honored Contributor

Could you attach the screenshot of the tool with filled parameters (before running the tool)?

Reply
0 Kudos
Highlighted
New Contributor III

Here they are.

Reply
0 Kudos
Highlighted
Honored Contributor

Another tool would be Extract by Polygon—Help | ArcGIS for Desktop . Spatial Analyst extension required to run this tool.

Reply
0 Kudos
Highlighted
Honored Contributor

Close all ArcGIS Desktop applications. Open a new/blank ArcMap session.

Add the raster and polygon to the AcMap.

Run the tool (Also save the output Raster to a smaller pathname, not in the default.gdb; Also NO space and use underscore instead of any special character)

e.g. D:\Project\Data_2011.gdb\Jamuna_2011

View solution in original post

Highlighted
New Contributor III

And finally this works! Changing the default output location! I can't stop laughing    Anyways, Dhonnobad (assuming from your name that you are a Bangali)!