Can't Register table with Geodatabase - Arc 10.1, SQL 2008

06-15-2016 10:22 AM
New Contributor

I have database that is named xytest and it contains multiple table of point and line features.  The database was created by a third party application.  In Arc Catalog Geodatabase has been enabled for the database.  When I right-click a table and go to Mangage, everything is greyed out and not available.  I looked in sql to verify I am using the correct login.  SQL show the owner of the database is xytest.  In SQL under the database->Security->Users the user 'dbo' is xytest.  If I perform a SELECT statement on dbo.SDE_layers the only item is GDB_ITEMS and it shows and owner of 'DBO'.  In Arc Catalog I have tried to login as the 'xytext' user and I am still unable to perform and functions under Manage.

I did notice on the table I am trying to register with the geodatabase the Schema is xyz2016Temp.  I have created another user in SQL and set the default schema to the xyz2016Temp.  I have added this user to the database server roles of sysadmin and processadmin.  I made sure the user is a db_owner of the database and has all permissions turned on.  The functions in Arc Catalog under Manage are still greyed out.  I am at a loss of what to try next. 

I have created databases in the past, Enabled Geodatabase and registered the tables with the geodatabase.  I created another database to test and it worked flawlessly.

I have verified there are no locks on the database.

Any help and suggested would be greatly appreciated.

0 Kudos
2 Replies
Regular Contributor III

You will need to connect as the Data Owner (not the database owner) and perform those operations.

In ArcCatalog, the naming convention shows up as -- database_name.data_owner_name.object_name

so if the owner shows as DBO...connect as any login which has the 'sysadmin' server role assigned to it

If the owner shows as XYTEST....make sure the Default Schema for that login is set as 'XYTEST' as well and it does not have the 'sysadmin' server role granted to it.

To check Default Schema:

Open Management Studio> Connect to Instant> Expand Security> Expand Logins> R-Click on the Login> Properties> User Mapping> Check the desired Database

0 Kudos
New Contributor

After reading your reply I looked a little closer.  My database looks something like this: dbo.GDB_ITEMS, dbo.GDB_XXX, dbo.SDE_layers, dbo.SDE_xxx.  Then I have xyz2016Temp.point_tables and xyz2016Temp.line_tables. I am trying to register the xyz2016Temp tables with the geodatabase. 

0 Kudos