ArcMap - World Geocode Service Problem

2361
5
Jump to solution
12-22-2015 07:16 AM
Highlighted
Occasional Contributor II

Hello community!

 

I have a question that I can't seem to figure out. 

 

I find it very helpful to type in an address and being able to find it quickly.  I use the World Geocode Service from ArcGIS to help me with this.

 

All of a sudden though (for about 3 months now) it doesn't seem to work, and I am not sure why.  Now when I type in an address, it does nothing after I press Enter.  It used to find the address then I could right click the search bar and pan to it etc. 

 

Does anyone know what might have happened or what I can do to fix it?

 

I am not Geocoding, but I do have enough credits in my ArcGIS Online account. 

 

Capture.JPG

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Frequent Contributor

Kenric,

One thing to try - download Fiddler (Fiddler free web debugging proxy) on the machine with ArcGIS. Open ArcMap, then open Fiddler. You can make sure it's capturing traffic by going to google.com, or something. Once you've verified you're capturing traffic, attempt to geocode an address. You should see with a 200 response from geocode.arcgis.com - if you do not see this request, it was never sent. If you see the request, but you have result other than 200, your firewall may be blocking it... Actually, in either case, your firewall could be causing blockage...

View solution in original post

5 Replies
Highlighted
Frequent Contributor

Kenric,

One thing to try - download Fiddler (Fiddler free web debugging proxy) on the machine with ArcGIS. Open ArcMap, then open Fiddler. You can make sure it's capturing traffic by going to google.com, or something. Once you've verified you're capturing traffic, attempt to geocode an address. You should see with a 200 response from geocode.arcgis.com - if you do not see this request, it was never sent. If you see the request, but you have result other than 200, your firewall may be blocking it... Actually, in either case, your firewall could be causing blockage...

View solution in original post

Highlighted
Frequent Contributor

E.g. something like:

FYI, Fiddler can capture ssl traffic, but you shouldn't need to set this up for this debugging.

Highlighted
Occasional Contributor II

Thank you Chris!  With your help we were able to figure it out.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Care to share what the problem was?

Reply
0 Kudos
Highlighted
Occasional Contributor II

Sure.  It was the firewall.  We just had to fix that and it worked!

Reply
0 Kudos