ArcCatalog 10.2: inconsistent connections to Oracle DB

09-30-2013 03:11 PM
New Contributor
Hi all. I recently installed ArcGIS 10.2 for Desktop on a desktop PC that previously ran ArcGIS 10.0 for Desktop. The install completed without error. Unfortunately, I have experienced issues connecting to our databases using ArcCatalog.

I tried using several different 32-bit Oracle clients. The full client (v. was installed initially, but I also tried three other versions including two versions of the instant client. In each instance, ArcCatalog was unable to establish a database connection, but I could connect using SQL*Plus. At this point I ruled out a TNS problem, especially since ArcGIS 10.0 and 10.1 worked fine.
Next, I uninstalled ArcGIS 10.2 for Desktop and installed ArcGIS 10.1 for Desktop. Making no other changes I was able to successfully establish a connection in ArcCatalog.

Finally, I upgraded ArcGIS 10.1 for Desktop back to ArcGIS 10.2 for Desktop. I have been able to establish a few database connections using 10.2, but if I close and re-open ArcCatalog the connections hang. On some occasions I can reconnect if I reboot the PC, but this does not always seem to be the case. Moreover, I have experienced this problem on two desktops and a laptop so it does not appear to be isolated in my environment.

Has anyone else encountered this issue? Thanks!

Server Configuration
�?� Windows Server 2008 R2 Enterprise Service Pack 1
�?� Oracle Enterprise Database 11gR2 v. (64-bit)
�?� ArcGIS ArcSDE for Oracle11g for Windows 64 version 10.0.2400 (direct connection)
�?� Geodatabase version = ArcGIS 10.0 Service Pack 5

Client Configuration
�?� Windows 7 Enterprise Service Pack 1
�?� ArcGIS 10.2 for Desktop

Oracle 32-bit Clients Tested
�?� Oracle Client
�?� Oracle Client
�?� Oracle Instant Client
�?� Oracle Instant Client
0 Kudos
0 Replies