Aggregate gives incorrect results, are there known cell factor limits?

10-02-2012 10:13 AM
New Contributor
Greetings,  I'm using 'aggregate' to resample a raster to get the maximum of values in a cell, and the results are incorrect.
The input raster has a single value, though alternately I've tried with the nodata values filled to zero. I've tried this many different ways and the resulting raster appears to be based on only the central value in the grid cell, and is not calculating the maximum.   I didn't immediately catch this problem because the results appeared to be reasonable until I overlaid the two rasters and then the error is glaring.

I'm using a snap raster and have set the output cell size to that snap raster as well, and the output from the tool has the correct cell size and is correctly snapped.

I've also tried using the sum, minimum, and variations on the 'data' and 'nodata' settings, with identical results. It's clearly wrong that the 'sum' setting gives a value output table that only has a single value and has not summed anything.

FWIW there is a pretty large difference between my input and output cell size (~30 x). The results are identically incorrect in versions 10 and 10.1.

Is there something really obvious here that I'm missing?  I thought about using the resample tool, but the 'search' option that used to be in the command line function is not available in toolbox (I need this to make sure that any positive occurrence in the finer grid is carried over as a positive occurrence in the coarser grid). When I do use the resample command with the 'search' option in an arc-info command window the process consistently hangs at 7% for hours (this is a large grid).

0 Kudos
1 Reply
New Contributor II

Don't use the snap raster for the cell size, use Cell Factor as a multiplier to set your output cell size.

0 Kudos