0509-150   Dependent module libskgxp11.so could not be loaded

4153
1
Jump to solution
11-26-2013 08:19 PM
EmadAl-Mousa
Occasional Contributor III
Error faced while starting up ArcSDE:

Enter password:
exec(): 0509-036 Cannot load program oracleoradbd because of the following errors:
0509-150 Dependent module libskgxp11.so could not be loaded.
0509-022 Cannot load module libskgxp11.so.
0509-026 System error: A file or directory in the path name does not exist.
ERROR:
ORA-12547: TNS:lost contact




My Current Environment:

Oracle11gR2 (11.2.0.3.8)
ArcSDE 10.0
Server: IBM AIX


I had this error while cloning the oracle database from one server to another.
0 Kudos
1 Solution

Accepted Solutions
EmadAl-Mousa
Occasional Contributor III
The solution is the following:

*.* Sticky Bit permission *.* and Relinking the libararies

chmod 6751 $ORACLE_HOME/bin
ls â??l oracle

also,

chmod 6751 $ORACLE_HOME/lib

Then, use the unix command:
relink all


then i tried starting ArcSDE and it works fine.
Also, make sure while you are in the server using "sde" unix user account to try "sqlplus" and enter your "sde" user account and password....it should work fine.

View solution in original post

0 Kudos
1 Reply
EmadAl-Mousa
Occasional Contributor III
The solution is the following:

*.* Sticky Bit permission *.* and Relinking the libararies

chmod 6751 $ORACLE_HOME/bin
ls â??l oracle

also,

chmod 6751 $ORACLE_HOME/lib

Then, use the unix command:
relink all


then i tried starting ArcSDE and it works fine.
Also, make sure while you are in the server using "sde" unix user account to try "sqlplus" and enter your "sde" user account and password....it should work fine.
0 Kudos