Unexpected colors when making NDVI from Landsat bands

382
1
12-13-2023 08:15 AM
BrianKron
New Contributor

Hi everyone, not sure if this is the proper spot, but I can't access any sort of help board, so I was wondering if the community could help answer a question I have. I'm making NDVI layers from Landsat data, but I've run into a couple of snags. I'm using ArcMap 10.2.2. 

First, when I'm making a composite band from all 7 bands from 6/7/23, and set the R/G/B to bands 4/3/2, respectively, as I believe I should be, the color of most of the map turns a purpleish hue. This is despite other composite bands from other dates this year reflecting what seems to be 'true' color when I follow the same steps with them. I've tried reimporting the bands and making a new map, but the same thing happens, and the bands are only named as they came labeled from Earth Explorer, so I know I didn't mix them up. Does anyone have experience with this issue or know what the problem might be? (I've attached a picture of the purple map) 

Second, and this may be more ambiguous, but just for the sake of being thorough, because of the issues with the layer mentioned above, I've tried importing some previous data, compiled by a colleague, that I used in a different map. So far, the values when doing the NDVI process again turn out different values (specifically the max/min shown in the table of contents. Our original map was (through several steps) projected into another coordinate system. Is it possible that the differences in coordinate system could be causing this difference? The maps *look* pretty much the same but I'm concerned I'm using the wrong values for my analysis. 

Thank you all, I really appreciate it! 

Tags (3)
0 Kudos
1 Reply
BrianKron
New Contributor

Sorry, forgot to add the picture of the odd coloration layer. Not true to life colors.png

0 Kudos