Downloaded Story Map Tour Won't Load

3504
15
Jump to solution
12-31-2015 02:02 PM
KyleWikstrom
Occasional Contributor II

It seems that others have posted here of similar issues: downloading the Story Map Tour template, updating the webmapid and experiencing the map tour getting stuck "loading" in the web browser. Unfortunately, none of the articles or answers I've found so far have been able to help.

I created a Story Map Tour in ArcGIS Online, and in the builder I created the point locations and uploaded images/thumbnails, added descriptions etc. This created the web map for me. I downloaded the Story Map Tour template and updated the webmapid in the index.html file with the web map's id but the Story Map Tour will not move beyond the loading screen. I checked for errors here (My Stories | Story Maps ) but there are no errors.

This is the web map: http://pwa.maps.arcgis.com/home/webmap/viewer.html?webmap=77a28174b7e047928f9f19f19da5fe52

This is the URL to the downloaded Story Map Tour we are hosting: http://ec2-52-7-234-52.compute-1.amazonaws.com/apps/MapTour/

I certainly appreciate any help that can be offered. It will be really nice to take our story even further! Thanks much, and Happy New Year!

Reply
0 Kudos
15 Replies
AravindStoryMaps
Esri Regular Contributor

No worries, Kyle. Happy new year from one UC 14 assistant to another

Aravind

KyleWikstrom
Occasional Contributor II

I went to the LAN Settings and the item you described is unchecked. "Automatically detect settings" is the only item checked.

Reply
0 Kudos
KyleWikstrom
Occasional Contributor II

Tell me about proxy pages. Let's try this route.

Reply
0 Kudos
KyleHeideman1
New Contributor II

Took a quick glance and wonder if there is a directory structure issue? It's acting like a portal deployment:

// If the template is deployed on a Portal (apps path contains /apps/MapTour/ or /home/MapTour/)

  // commonConfig.js is loaded from the parent folder, otherwise it's loaded from the app folder

Your Amazon hosted version is 404ing while loading the commonConfig.js ... it's looking at  http://ec2-52-7-234-52.compute-1.amazonaws.com/apps/commonConfig.js?v=2.4.0.js

I believe that file is typically found(using your structure) in: apps/MapTour/app

Reply
0 Kudos
GregoryL_Azou
Regular Contributor II

Sorry about your issues. Kyle diagnosis above is correct, the app won't works if deployed on your server over '/apps/MapTour/'. Just change the name of one of those directory and it should loads.

View solution in original post

KyleWikstrom
Occasional Contributor II

I moved the MapTour folder that contains the app files out of the folder named "apps" and it appears to be working now. Thank you!