Delete Section in Story Map Journal Builder after Saved

1740
4
Jump to solution
10-16-2017 10:48 AM
KellyMeehan3
New Contributor

I'm using the Story Map Journal Builder and have been using the "Organize" button delete sections in the Story Map. There used to be a little trash can on the right of the title for each section. However, now that I've hit "SAVE" in the upper right hand side of the Builder, I can move sections, but I can no longer delete them. Instead, I can only choose between Published and Hidden on the Status drop down menu for each section title in the Organize dialog box. 

My question is: how can I go back to having the option to delete sections in the Organize dialog box?

0 Kudos
1 Solution

Accepted Solutions
RupertEssinger
Frequent Contributor II

Hi Kelly

I can only reproduce this if one of the sections in my Map Journal has an usually long title with no spaces in it. For example if the title of my section is that long Hawaiian fish name (humuhumunukunukuapuaa) it partially clips the Delete icon but I can still click it. Does one of your section titles perhaps start with a long word with no spaces in it? If so, editing that title to break up that first word, and then going back to the Organize dialog should let you access the Delete button.

If that isn't what is going on, could you also let us know which web browser you are using and also which operating system (Windows 10, etc).

Rupert

View solution in original post

0 Kudos
4 Replies
RupertEssinger
Frequent Contributor II

Hi Kelly

I can only reproduce this if one of the sections in my Map Journal has an usually long title with no spaces in it. For example if the title of my section is that long Hawaiian fish name (humuhumunukunukuapuaa) it partially clips the Delete icon but I can still click it. Does one of your section titles perhaps start with a long word with no spaces in it? If so, editing that title to break up that first word, and then going back to the Organize dialog should let you access the Delete button.

If that isn't what is going on, could you also let us know which web browser you are using and also which operating system (Windows 10, etc).

Rupert

0 Kudos
KellyMeehan3
New Contributor

Thanks so much Rupert for taking a look at this. There were some long first words in there, however I went in and broke them up, and still had the same issue. I'm using Chrome and my operating system is Windows 10. However, the dialog box looks the same in Mozilla. I've also tried making copies, but those do the same. Any suggestions would be greatly appreciated-- thanks!

0 Kudos
KellyMeehan3
New Contributor

Ah-- I can actually see the delete icon when dragging the item. It's at the end but then disappears when docked to the new location!

0 Kudos
OwenGeo
Esri Frequent Contributor

Hi Kelly -- Looks like this is a bug. We'll fix it in the next release in early December.

For now, if you need to organize the sections of your journal you can temporarily fix the issue by adding some CSS in Chrome's dev tools. This won't last between builder sessions (if you reload you'll need to do this fix again). See below. Let me know if you have any questions.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos