Polygon labels not centered

341
3
Jump to solution
11-18-2019 07:17 AM
MatthewLeonard
New Contributor III

How can I ensure that polygon labels are roughly centered over the visible portion of the polygon?

In this example, the OH and PA labels are positioned nicely, but the NY label is almost at the edge of its polygon - I would like it to be more centered.  I have seen many instances of this problem.

I'm using ArcMap 10.3 with Maplex label engine enabled.  (EDIT: I should also add that I'm using Data Driven Pages to automatically generate the extent of each map based on feature attributes.)

The colored line layer has a feature weight of 1000, so labels will not overlap it.  But I would like the NY label to be placed as close the center of the visible portion as possible without overlapping the green line.  If I force the label to stay at the center of the whole polygon, it will sometimes be outside the extent of the data frame, in cases like NY as shown, and this is not desirable.

The states polygon layer is using Regular Placement. It has interior feature weight of 0 and boundary feature weight of 1000.  I tried Land Parcel Placement also, and I looked through other placement properties options.

polygon labels not centered

0 Kudos
1 Solution

Accepted Solutions
MatthewLeonard
New Contributor III

OK, I solved this.  I previously had the Label Buffer for the states layer set to 30%.  I don't know why this would matter in this case, since there aren't any other labels on this map that would be near each other.  But for some reason, after I changed the Label Buffer to 0%, the labels shifted towards the center of the visible portion of their respective polygons on each page, pretty much how I wanted.

maplex label buffer

View solution in original post

3 Replies
JosephCarter
Occasional Contributor

Hi, Matthew. You have a lot of options to get the labeling results you are looking for. Here is one:

Export your state layer to a feature class. In Design View, create a rectangle of your study area. Select the rectangle graphic and use the "Drawing / Convert graphics to features" on the Draw toolbar.

Now use the Clip Geoprocessing Tool with the states layer, clipping with the new clip feature.

Go to Layout view with the newly clipped states layer zoomed to your study area.

In Maplex, give the Interior feature weight 900 and the Boundary weight 200, Check Background Label, uncheck all in Label density and Fitting Strategy. In Label Position, use Horizontal. OK.

Good Luck!,

Joe

0 Kudos
MatthewLeonard
New Contributor III

Good thinking Joe.  However, I forgot to add that I'm using Data Driven Pages to automatically generate the extent of each map based on feature attributes.  Given that, your approach doesn't let me accomplish what I want in this case.  But it could be a good workaround for some other scenarios.

MatthewLeonard
New Contributor III

OK, I solved this.  I previously had the Label Buffer for the states layer set to 30%.  I don't know why this would matter in this case, since there aren't any other labels on this map that would be near each other.  But for some reason, after I changed the Label Buffer to 0%, the labels shifted towards the center of the visible portion of their respective polygons on each page, pretty much how I wanted.

maplex label buffer

View solution in original post