Register Dll with ESRIRegAsm.exe

4264
4
06-06-2011 08:27 AM
MichaelVolz
Esteemed Contributor
To All ArcGIS Developers:

I have watched an ESRI Deployment video as well as read ESRI v10 Resource Help and I created a bat file as follows which should just register a dll on a machine where ArcGIS Desktop is installed:

C:\Program Files\Common Files\ArcGIS\bin\ESRIRegAsm.exe C:\GIS_Testing\Test_Editor\Register_Testing\County.GIS.TestEditor.dll /p:desktop

When I run this bat file a dialog box pops up asking me which Registered ArcGIS installation I want to register this dll with.  I thought I already specified this option with the "/p:desktop" parameter.  Why is this option ignored?

I first ran the following bat file to create a reg file to be installed with the custom application:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe
C:\GIS_Testing\Test_Editor\Register_Testing\County.GIS.TestEditor.dll /p:desktop /codebase /regfile:C:\GIS_Testing\Test_Editor\Register_Testing\County.GIS.TestEditor.dll.reg

The dialog box also pops up here asking which Registered ArcGIS installation I want to register this dll with?  Again I had supplied this parameter so I do not understand why the software is still asking me for this information?

Any help you can provide is greatly appreciated.  Thanks.
0 Kudos
4 Replies
AlexanderGray
Regular Contributor II
Did you specify the version number?  (/v:10.0)
0 Kudos
UsmanAleem
New Contributor
Try this one

Register: ESRIRegAsm.exe <assembly name> /p:<product name> [Options]

Options:
/u -- Unregister types
/s -- Silent (display no dialogs)
/e -- Display error console
/v:<version> -- Version number
/regfile[:fileName] -- Export to registry file
/f:<category info file> -- category mapping file(.xml or .reg)
/w:<dirPath> -- keep working files.

so you need to add /s at the end of you line.
0 Kudos
MichaelVolz
Esteemed Contributor
To usmanaleem:

I did not mention it in the post, but I also tried with the /s at the end and the dialog box still popped up.  In addition, I thought the /s would only stop the success pop-up box from appearing indicating whether the dll was registered successfully or not.

To agray1:

I tried with the version set to 10.0 as you mention, but the dialog box still appears.

Can either of you see the behavior of registering this dll without the dialog box appearing on your machines?  Thanks for your assistance.
0 Kudos
AlexanderGray
Regular Contributor II
I can run this no problem with ArcGIS10 Sp1.  esriregasm.exe <path.dll> /v:10.0 /p:desktop /s
Perhaps it is a problem with the assembly itself?
Cheers
0 Kudos