How to Bind application developed using ArcEngine v10 to work on ArcGIS Desktop v9.3

331
1
02-25-2011 05:17 AM
Highlighted
New Contributor
Using the below mentioned source code, I am able to bind the Runtime for ArcGIS 10, but if I want to deploy the same application on other system having ArcGIS Desktop License 9.3, I am unable to do the same. Can anyone please guide me how to bind 9.3 environment in below mentioned code:
---------------------------------------------------------------------------------------------
using System;
using System.Collections.Generic;
using System.Windows.Forms;
using ESRI.ArcGIS;


namespace Controls
{
    static class Program
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main()
        {
            Application.EnableVisualStyles();
            Application.SetCompatibleTextRenderingDefault(false);


            if (!RuntimeManager.Bind(ProductCode.Engine))
            {
                if (!RuntimeManager.Bind(ProductCode.Desktop))
                {

                    MessageBox.Show("Unable to bind to ArcGIS runtime. Application will be shut down.");
                    return;

                }
            }

          
               
            Application.Run(new My_Tool.frmLogin());
            }
    }
}
---------------------------------------------------------------------------------------------

Is there any other way using which I can run application developed using Engine 10 into previous versioned license...


Thanks in Advance!!!


Regards,
Er. Alekhya Datta [WTI-ATL (TCS, Chennai)].
Reply
0 Kudos
1 Reply
Highlighted
Regular Contributor III
You can't.  ArcObjects are not backwards compatible.  Your application can only run on machines that have the same version you compiled against (or higher in most cases).
Reply
0 Kudos