Empty FeatureClass with Invalid Extent

02-26-2013 09:00 AM
New Contributor III
I ran into an interesting situation today.  I am doing some spatial reference changes to an SDE geodatabase.  For the most part, my process of changing the spatial reference, updating the X/Y coordinates of the features and then updating the domain, extent and spatial indexes is working well.  But I have this one feature class that has no features yet the extent of the layer when added to a map shows up with values in the old coordinate system.  Given that I've changed the spatial reference already, I get the warning of inconsistent extent.  If I use IGeoDataset.Extent, I get an empty envelope.  I've called IFeatureClassManage.UpdateExtent and I still get an empty envelope from IGeoDataset.Extent and still get the inconsistent extent warning when adding to a map.  In the end, I had to add a feature, make sure the extent it updated to valid coordinates, then delete the feature.  The updated extent still shows in a map and the IGeoDataset.Extent is still empty.  Other empty FeatureClasses don't show any extent when adding to a map.

Any ideas where this FeatureClass might still be holding on to some extent value that I'm missing?  Thanks.
0 Kudos
0 Replies