COMException rasied while creating raster workspace.  Error: 0x80040111

11-28-2014 10:15 AM
New Contributor



I have  started developing a C# application with Visual Studio 2013 with framework 4.0 and ArcObjects 10.  I have a .gdb file as input which contains one raster tif dataset.  My goal is using ArcObject to open a workspace and read its raster dataset attributes.


When running "IWorkspaceFactory workspaceFactory = new RasterWorkspaceFactoryClass();", I go an exception on an error as screenshot below.


We tried the solution on this link below.  Adding reference to ERSI.ArGIS.Version assembly.  That somehow worked only once.   After first calling to the assembly, however, the same exception was raised afterward.  It seems VS lost its link to the assembly.


Then, we tried using ESRIRegAsm.exe utility to register the assemblies.  But we no luck.  The same exception is still raised.


I have tried the same application on different machine with VS 2012, but still no luck.


Please, I need any advice on how to debug this problem.


Here is the exception.


Thanks in advance.


Tags (2)
0 Kudos
0 Replies