Backward Compatibility of ArcObjects

205
2
09-25-2018 07:59 PM
MatsHardy
Occasional Contributor

My client has ArcMap 10.4.1 and I developed an add-in on ArcObjects 10.4.1. The add-in works fine on my client's ArcMap.

Now, I wants to upgrade my ArcObjects to 10.5.1. If I have compiled the add-in with ArcObjects 10.5.1, will the add-in work on my client's ArcMap?

0 Kudos
2 Replies
KeithOlsen
New Contributor III

Probably, but you would have to test it out on a 10.4.1 machine. The big arcObjects shift came between 10.3 and 10.4 when they went to the MS 4.5 .NET framework. Generally, my 10.6 addins will not work at 10.3.

DuncanHornby
MVP Frequent Contributor

Stating the obvious but worth it anyway, if you have used an interface or calling a tool that was introduced in 10.5.1 then I would say it would definitely not work on 10.4.1!

My personal experience is that addins are not backwardly compatible and you would need to stick at 10.4.1 to ensure compatibility.

0 Kudos