ArcObject 9.3 to ArcObject 10

543
3
03-10-2013 07:18 AM
Highlighted
New Contributor
Hello!

I wrote a software programm in VB.net and ArcView9.3.
To be able to change in a pGDB  the attributes of the feature-class I have embadded the following references
Esri.ArcGis.Geodatabases
Esri.ArcGis.Geometry
Esri.ArcGis.System
Recently I have changed to ArcView 10 and installed the ArcObject SDK 10.
I replaced the reference from ArcView 9.3 with ArcView 10.
Due to this I receive the following error message:
Retrieving the COM class factory  for component with CLSID {FDFEBD95-ED75-11D0-9A95-080009EC734B} failed due to the following error: 80040111

I need help to solve this problem.
Reply
0 Kudos
3 Replies
Highlighted
Regular Contributor II
If this is a standalone application (exe) the way you check-out licenses and bind to products has changed.  Check-out this previous thread.
http://forums.arcgis.com/threads/63022-What-is-Error-error-80040111-Please
Reply
0 Kudos
Highlighted
New Contributor
Hello agray1!

Now it works. Thanks a lot!
Reply
0 Kudos
Highlighted
New Contributor III
Hi,
I am getting the same problem, and I have binded the Engine license, actually twice to make sure, but no luck. could you please tell me exactly what you changed and where? maybe mine is in the wrong place, although I don't know how, since the binding is the first thing done in the LicenseInitializer class. is there something else I need to do before I make an AO instance, because it happens on this line everytime...

pGxDialog = New GxDialog

although the same with other objects as well.

thanks.
Reply
0 Kudos