ModelBuilder: Append 000572 error

463
3
09-05-2018 07:38 PM
MarkShymanski
New Contributor III

I am attempting to append a feature layer into another empty feature layer of the same structure in ModelBuilder.  I get an 000572 error which apparently means the source and the output of the append cannot be the same, and that the solution is to change the output name.  I do this in modelbuilder and it automatically changes the source target name.  If I run append from ArcMap directly I can easily execute the append of the blank target datset with the populated source datset with no error messages.  I am using ArcGIS 10.4 Any help would be greatly appreciated.

0 Kudos
3 Replies
ConsumersAdmin
New Contributor

Having same issue, did you end up finding a solution to this?

0 Kudos
ChrisDonohue__GISP
MVP Frequent Contributor

I ran a quick test and Append appears to work fine in Modelbuilder in ArcGIS Desktop 10.4.1  Maybe something in your particular setup is affecting it?  Some things that may be influencing it:

  • How is the data stored?  Is it in an Enterprise Geodatabase (SDE)?  If so, there can be a whole variety of complications.
  • Any chance Network permissions are affecting this?  One way to check on that is try putting all the data on your C: drive and then running Modelbuilder.
  • The Error message does seem odd, as by definition Append adds the data from one feature class to another.  Can you confirm that the Append process being used is the standard geoprocessing tool "Append (Data Management)"?  Or is this a different Append geoprocessing tool (there are several) or a custom Append tool?
  • You may want to contact ESRI Technical Support, as this issue does seem strange.

Chris Donohue, GISP

MarkShymanski
New Contributor III

Hello Chris,

The data were held in a file geodatabase on a networked drive.  I did contact ESRI  but time pressure to get the task done precluded me from doing too much investigation to resolve the issue and I went with a 'plan b' solution using merger instead.  I was using the stock Append from the 'data base management' toolset. I had involved our IT folks to rule out any network access, ownership or permissions issues.  I will need to revisit this at some point in the not too distant future but for the next 3 days or so it will be on the backburner.

Mark

0 Kudos