Max record count error for service error

2105
6
07-19-2018 11:23 AM
EmilySangster2
New Contributor II

I have a service which is displaying the following error on our ArcGIS server log:

MaxRecordCount limit reached; ignoring any remaining objects in the query result for Table: Asset Existing Deficiencies.

The service has a max record count in the parameters set to be 10,000 and the total number of records in the tables in the service adds up to 3,500. 

Is there anything else that could be causing this error? 

6 Replies
JoeBryant2
Occasional Contributor II

Hi Emily,

Did you ever solve this?

I get the same error, but mine actually lists the max record count as "6", which has me baffled. The particular service that returns the error has a max record count set to 1000 in each layer. And the service returns many more features than 6 in the Web Map display, just slower than I would like.

This leads me to believe that some other process is being limited to 6. Which has me suspecting the Search widget tool in our app, which uses fields from this service in its query and limits the search results to the first 6 matches. But I wouldn't think this would be logged as an error. And we get the errors when just viewing the service, without using the search widget in the app.

Has anyone else experienced this? Is the Search widget sending me down a rabbit hole with it's "error" messages?

0 Kudos
EmilySangster2
New Contributor II

Hi Joe,

I didn't resolve it! I was using feature classes with relationships to non spatial tables in the Collector app.  I'm not sure but I suspect the issue was related to how I had set up those relationships.  The error would appear when viewing the feature service in AGOL as well as when it was viewed in the collector app.  It didn't cause any errors on the field users side when they collected data and synced but a foreign key was being removed from one table and I thought the count error might have been related to that.  I did have the search function enabled on the web map in AGOL so perhaps the errors are similar? I didn't use any custom search widgets.

 Cheers,

Emily

0 Kudos
MichaelVolz
Esteemed Contributor

Do you think that the relationships are working as expected with respect to the non-spatial tables?  I ask because I thought AGOL only recognized relationships based on relationship classes where the feature class and it's related table are both stored in the same geodatabase.

Would you have the ability to copy the non-spatial data to your GIS geodatabase, create a relationship class in that geodatabase and see if you get better results?  Not sure if this would be possible for you and it would probably require scripting for you to get the table into the GIS database if the data gets updated on a regular basis and you need to keep it current.

0 Kudos
EmilySangster2
New Contributor II

Hi Michael,

All the features involved in the relationship including the tables were stored in one geodatabase and performed as expected when tested through ArcMap.  They were set up as 1:M with no message sent between feature classes.  I guessed the relationships might be the issue only because it was my first time using them in the Collector app.

Cheers,

Emily

0 Kudos
AndrewWhitman1
Esri Contributor

Greetings Emily, 

I have a few questions regarding this service and I would like to suggest a few potential troubleshooting steps. 

--What kind of database is this being held in? Enteprise Geodatabase? If so what type? (Oracle/Sql Server?) 

--Does this error only occur with the relationship class? 

I wonder if we increase the record count within ArcGIS Server Manager, if this would allow us to complete your workflow here. 

So If I log into ArcGIS Server Manager and navigate to Services, then

--Find the service we are working with. 

--Click on the service, and navigate to "Parameters" 

--For "Maximum Number of Records Returned by Server" is this set to 2000? If so, can we try increasing it? 

--For the value Maximum number of coded domains what is this set at? Does the table have coded domains? 

--Under pooling, can we increase the minimum number of instances or the timeouts for this service? 

When you consume this same service in ArcGIS Online within a web Map do you receive an error? 

Sincerely, 

Andrew

EmilySangster2
New Contributor II

Hi Andrew,

The database is SQL and the record count error only occurs with one table that is in a relationship class with a feature class that has several relationships to other tables. The relationships are set up with the same parameters but only one table had an issue where a foreign key was deleted. Editing of this field was also restricted so I know field staff weren’t deleting them. I tried increasing the record count to 10,000 as a test to see if it would resolve the issue and the error continued. The total number of records in the database was 3,500 so I thought 10,000 would cover it if that was the issue.

There were coded value domains in the feature class and table. The max number under the parameters is set to 25,000 which is the default. Does the 25,000 relate to the different domains in the database or all of the possible values of all of the domains?

The error occurred when viewing the data in AGOL in a web map and when data was viewed in the Collector app.

Cheers,

Emily Sangster, Adv. Dip. | GIS Mapping Technician

McElhanney Consulting Services Ltd.

D 604 424 4847 | T 604 683 8521

esangster@mcelhanney.com<mailto:esangster@mcelhanney.com>

0 Kudos