Layers do not show up past 1:1,000 zoom once basemap is added

780
4
04-09-2021 09:38 AM
Labels (1)
NicholasC
New Contributor

I am using ArcMap 10.8.1 and have been living with this strange error for a few months now

When I add a basemap, all my layers disappear and will not come back when zoomed past 1:1,000 scale. This is the case for every map I have and the examples below are from a fresh map I just created. ArcMap also slows down significantly when zoomed in this far which also makes me think something weird is going on. I dont have any settings enabled that do not show layers past a certain scale. When I am zoomed in past 1:1000 and turn off the basemap all of my shapefiles come back.

1:1,000

NicholasC_0-1617985934498.png

1:800

NicholasC_1-1617986005959.png

 

Here's the weirder thing. When I add the basemap from the arccatalog rather than from the add data button on the toolbar I do not have this issue. Arent these the same basemaps?

NicholasC_2-1617986139203.png

 

Tags (2)
4 Replies
JayantaPoddar
MVP Esteemed Contributor

Interesting. What are the things have you tried? 

Try these options. You may stop at the step if the issue gets resolved.

1. Clear display cache in ArcMap

2. Remove Spatial Index of the shapefiles and feature classes

3. Restart ArcMap.

4. Perform a soft ArcGIS Desktop reset. Reboot your machine.



Think Location
0 Kudos
TonyDeLaRosa
New Contributor II

Same problem here. Zoom past 1:1,000 and my data will disappear with an AGOL basemap. Haven't tried the import through Catalog.

Clearing cache and restarting ArcMap and computer and didn't seem to solve the map issue. Tried concept on a new map document and data loads fine.

Ditched the old mxd and used a new one with local organization data for basemap.   

0 Kudos
TonyDeLaRosa
New Contributor II

Turning off hardware acceleration fixed the issue for us. May want to give that a try. 

0 Kudos
JoeBryant1
Occasional Contributor II

My users are reporting the same issue, and I have confirmed the issue in multiple MXDs. We are on 10.7.1 using Windows 10 Enterprise, both physical and virtual machines. 

I have created a custom basemap group in Enterprise for our users that re-shares a curated group of ArcGIS Online raster basemaps that are still compatible with ArcMap (the default basemap list from ArcGIS Online now includes vector basemaps that are not compatible with ArcMap). We get the same inability to render layers when zoomed beyond 1:1000 when adding basemaps from ArcGIS Online or logged in through out Portal.

I created a GIS Server connection to services.arcgisonline.com, as Nicholas shows, and added the World Street Map from the Catalog pane, and can confirm that this does NOT cause the issue. To answer his question, yes, the basemap and the GIS Service are the same rest endpoint. BUT... one is being added to a Basemap group in the TOC, which Arc processes differently than other layers.

I created a new basemap group in the TOC, and moved the working GIS Service added from Catalog - the behavior returned. When I moved the service out of the basemap group, everything rendered properly again.

I tried the inverse - adding a basemap form the drop down and then moving it out of the basemap group. This also fixed the problem.

Lastly, I tried turning off hardware acceleration, as Tony mentions. At first, this caused Arc to act buggy - when I tried to add a basemap, the window would pop-up quickly and then automatically close. I restarted Arc and was able to add a basemap with hardware acceleration turned off. I got this pop-up:

JoeBryant1_0-1654902081739.png

The map works with a Basemap group and hardware acceleration turned off, but it is very slow. I think removing the basemap service from the basemap group in the TOC is a better fix.

Something about the interaction of hardware acceleration specifically for the basemap group when using a map service must be causing this unintended issue. I am planning on submitting it to Support as a BUG.

0 Kudos