I can't open some of coworker's mxds, he can open all of his. Might be XY Event Layer issue.

477
1
01-31-2022 06:10 AM
Labels (1)
CaraWiebalk
New Contributor II

He created a dozen mxds. I can open 2 of them, when I try to open the rest I get an error saying:

"Opening the selected ArcMap document failed.

An unexpected error occurred while loading the map document.

The last successfully loaded component was:

esri.Geometry.GeographicCoordinateSystem(*string of characters*)

The specified file does not contain a valid ArcMap document or was saved using a newer version of ArcGIS."

 

We are both running ArcMap 10.6.1. We are using a remote connection to the same machine. We have the same extensions running. He can open all of his files still. I have also tried:

It seems like the only difference between the maps I can open and the maps I can't open is that there is an XY Event Layer in the maps I can't open, made from a csv file.

 

I can import the map into Pro, however this project is for a client that requires ArcMap so that isn't a solution here.

 

 

Edit: For people who may run into a similar problem in the future... Part of the issue was related to the fact that I was using "Remote Desktop Connection" to remote into the computer AND had "Enable Hardware Acceleration" checked off in ArcMap. Unchecking that box allowed me to open some (though not all) of the mxds. It seems like ArcMap can open these mxds just fine with it Enable Hardware Acceleration checked off if I am using the computer directly (not remoted in).

 

0 Kudos
1 Reply
DanPatterson
MVP Esteemed Contributor

have you tried saving the event layer to your geodatabase instead?


... sort of retired...
0 Kudos