How to fix and avoid "Check to see that you have the appropriate permissions" error when trying to edit?

09-22-2020 12:37 AM
New Contributor

To explain our situation:

I have a geodatabase created, it is located on company's Onedrive, the GIS folders are synched to everyone's computer, but only two people have ArcMap 10.8 installed to work with our geodatabase. however we had OneDrive failure and we had to recover all geodatabase files (the recovery created some extra copies of some files with added computer numbers in their names - we managed to delete them).

One day we tried to edit some features and after clicking Start Editing the attached error showed. We searched online for solution but none fixed the problem. 

We tried:

  • Unchecking the Read-only option in the file geodatabase properties - but this change wasn't able to save itself,
  • Assigning full control permissions to edit the file geodatabase - we already had full control,
  • copying geodatabase to local drive (with all data files also) - same error kept showing.

What could be the cause of this error and how can we avoid it in the future?

Could this be related to having all files on OneDrive? or could editing be somehow blocked by IT security systems?

Is there a possibility to fix this issue, maybe by changing some settings?

or is the geodatabase corrupted and needs to be done from the begginging?

0 Replies