how to disable ArcGIS sign in pop up

6702
6
07-27-2015 07:13 AM
MartinTedd1
New Contributor

I have recently installed ArcMap 10.3.1 for desktop, each time I select "File" on the toolbar the attached pop up appears.

How can this be disabled? It is extremely annoying.

0 Kudos
6 Replies
JayantaPoddar
MVP Esteemed Contributor

Martin,

Does it help unchecking the "Sign me in automatically" check-box ?

0 Kudos
LaceyJohnsen
New Contributor

I am having the same issue after a recent upgrade to 10.2.1 and unchecking the "Sign me in automatically" check-box doesn't help.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Martin/Lacey,

You could try resetting your ArcGIS Application profile.

Resetting your ArcGIS application profile

0 Kudos
CoryCampbell1
New Contributor III

Hi,

We're experiencing the same issue, and it's detrimental to workflow (ArcGIS 10.3). As an administrator I'm always automatically signed in, but not all of our desktop users have named user accounts to AGO and should not be programmatically corralled into subscribing. To demonstrate how absurd this is, I just signed out and then clicked on the File dropdown menu four times and it resulted in four concurrent sign in prompts.

Unchecking the auto sign in option or recreating the Normal.mxt don't correct the problem. ESRI should not make use of something as central as the File menu conditional. The software should only prompt when a user is specifically attempting to access non-public AGO content or attempting to publish to AGO. At least offer a configuration option either in ArcMap Options or the ArcMap Advanced Settings Utility that would allow enabling/disabling this prompt.

0 Kudos
GerickeCook
New Contributor III

I was having the same issue and it was killing my productivity. I happened upon this thread and found the solution, though it wasn't related to this question: https://community.esri.com/thread/104559

When ArcMap opens, right-click on the globe icon in your tray to open the ArcGIS connection settings. Chances are your selection says something like "Always check at the start of a session". If you change it to "Never check", that sign-in popup goes away.

Note: This solution will disable the ability to add or use ArcGIS Online map services, but I'm willing to switch back and forth as needed than have that pop-up continuously disrupt my workflow.

AnthonySchaffer
New Contributor III

We also ran into this problem for one of our users following an upgrade to ArcGIS Desktop 10.3.1.  After some trial and error, and then opening a support case with ESRI, we found this solution:

Opened Regedit, then browsed to key: HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online\SignIn\www.arcgis.com.  For the affected user, there were entries there for AutoSign (value set to 1) and Password (value set to a series of hex numbers).   No entry for Username was present.   We deleted the AutoSign and Password entries from registry key.   After then, the problem no longer occurred in ArcMap.

It would seem that this problem is due to a combination of

a)      The ArcGIS Online sign-in-automatically setting is turned on

b)      The user’s stored password is incorrect, or a password was stored but no userID

c)      The ArcGIS Online sign-in dialog does not persist setting changes when the Cancel button is clicked. (We tried unchecking the option in the dialog for "Sign Me In Automatically" but it wouldn't stick following the Cancel button click.)