How can i force Arcmap to label polygons features always straight at any scale ?

575
2
06-16-2022 11:47 PM
Labels (3)
MAMDOUHZALAKY
New Contributor III

I want to label polygons features alwayes straight , but when i try to change the scale or make zoom out the label placement changed to be horizontal my question is how i can keep the lapel placement to be straight alwayes ? is there any solution or workaround ?

444.jpg666.jpg

Tags (3)
0 Kudos
2 Replies
RobertBorchert
Frequent Contributor III

it is doing that because the label is to long to fit in the polygon anymore.  If you are using Maplex

There are some options you can manipulate for the labels or alternative ways of doing things.

In label options when the label exceeds the size of the polygon it will go beyond

RobertBorchert_0-1655467929143.png

RobertBorchert_1-1655467960306.pngIn the setting you can turn off Overrun feature.  

RobertBorchert_4-1655468154616.png

 

However, when you turn that off the label will disappear when it gets to big. However you can turn on stacking

RobertBorchert_3-1655468091149.png

However, it will still disappear when you zoom out.

So you select Reduce Font Size and go into options and set the max amount it will reduce font size. 

Last you can try Abbreviate Label. For this you need to create abbreviation dictionary. 

 

The alternative is to create annotation.  Annotation will stay the same size relative to the polygon no matter how far out or in you zoom

 

0 Kudos
JesseWickizer
Esri Contributor

Uncheck the Try horizontal position first setting on the Maplex Label Position tab.

JesseWickizer_0-1655754143553.png

 

 

0 Kudos