Basemap thumbnails do not appear in ArcMap 'Add basemap' window

06-04-2018 12:40 PM
New Contributor

I have a customer who has an issue with Add Basemaps in ArcMap 10.3.  The basemaps window pops up, but with nothing in it (i.e. no thumbnails).  The same is true of 'Add data from ArcGIS Online'.  I read and tried every suggested remedy to no avail.  The machine is on a LAN behind a corporate firewall, but that doesn't seem to be at play, since I can log in with my user ID and pull up basemap thumbnails in the same ArcMap installation just fine.  I can also add the basemap service as a Database Server Connection and basemaps can be loaded directly just fine.  We can log in to both private and enterprise AGOL accounts from the File > Sign In menu option, but still no thumbnails.  If we try to sign in with the 'Sign In' button from the AGOL popup window (empty of tumbnails of course), however, ArcMap terminates, with the standard unexpected termination message.

One curiosity is that when I monitor the http traffic (using Fiddler), I notice that, with a user ID that works, you get the normal traffic requesting the service and downloads of each of the thumbnails, but when we are logged in as the problem user, there is no http traffic at all registered in Fiddler when 'Add basemap' is clicked, even though the (empty) basemap window pops up.

Can anyone tell me what the program flow is when the 'Add Basemap' function is selected?  What could possibly stop ArcMap from even trying to connect to AGOL (e.g. no message traffic appearing in Fiddler)?  I suspect a user setting somewhere, but I've tried renaming the ESRI folders in the Users\<user id>\AppData\Roaming\ESRI and HKEY_CURRENT_USER\SOFTWARE\ESRI folders, without effect.  IE Options "Automatically detect settings" is also unchecked.

0 Kudos
2 Replies
New Contributor II

I am currently experiencing this issues with 10.5.1. Were you ever able to resolve it?

0 Kudos
Esri Contributor

In my case the same issue occurred login the Portal for ArcGIS account in the ArcMap
This was because the Basemap group was shared only group member.

0 Kudos