Select to view content in your preferred language

ArcMap Open Failed Error opening feature class

05-11-2021 03:04 PM
New Contributor II

Hi there,

I'm looking for help on fixing an error while trying to add a new feature class into an existing feature dataset called Province. 

Error in Arc Catalog while pasting the new feature class called "Rivers" or importing:

Open Failed: Error opening feature class Layer not found [GIS. Communities] 

The feature class "Communities" no longer exists. It is not needed. This is a versioning environment using Oracle 12c.

I have tried different things such as re-creating the fc "Communities", I can see it on both sides inside Arc Map and also Oracle SQL. But, when I try to insert the new fc into fd, it doesn't let me.

I did admin database management: reconcile, post, delete all versions, compress, rebuild indexes, analyze, etc.

I also did the diagnose and repair version tables and metadata and they run successful without errors.

When, I run again rebuild indexes, I checked the python script log and that province/state was skipped. Then, I try to do it manually through arcmap. But, it doesn't let me to access it through properties. It looks like the issue is with the index and some broken links. I do need that feature class but I would like to keep the other feature classes.

You may have encounter this error before. I would like to repair it to keep the names of the other fcs. Your help is appreciated.




0 Kudos
1 Reply
Frequent Contributor III

Where is or what format is the feature class in?  Is it a shape file?

0 Kudos