ArcMap cannot start on remote desktop (Works fine when you login locally)

452
1
08-26-2021 07:59 PM
Labels (1)
RushiAmin3
New Contributor

I had a strange issue that ArcMap (if you are still using it :)) cannot open when I log in remotely on the machine. ArcCatalog worked without any issues. ArcMap also worked when login in directly on the laptop.

I went through numerous Esri articles that suggested printer settings, python environment, registry settings etc. with no luck. I also uninstall/install multiple times. 

Finally, the following article came to the rescue.

https://gis.stackexchange.com/questions/354867/arcmap-remote-desktop-connection-error-with-windows10

The error was related to the remote desktop group policy. Following the below will fix the issue:

  • Right-click on the Windows start menu and select Run (or windows+R)

  • type cmd

  • type gpedit.exe

  • go to "Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment"

  • set the following parameters to Enabled

    • Use hardware graphics adapters for all Remote Desktop Services sessions

    • Prioritize H.264/AVC 444 graphics mode for Remote Desktop Connections

    • Configure H.264/AVC hardware encoding for Remote Desktop Connections

  • set the following parameters to Disabled
    • Use WDDM graphics display driver for Remote Desktop Connections
1 Reply
David_Brooks
MVP Regular Contributor

That's really interesting. Will bear that in mind for other software as well.

Another less elegant workaround is to open software using Chrome remote desktop and then go back to working in Windows RD afterwards. Chrome RD works differently and isn't recognised by windows as a remote session in the same way.

I use this to open Global Mapper on my remote machine, because you can't open GM via RDP if it's a node locked licence.


David
..Maps with no limits..
0 Kudos