ArcMap 10.8 is getting hung up on basic joins and exporting layers - help!?

04-06-2020 01:55 PM
New Contributor

I use a (not amazing but not that old) PC laptop for my map work - and literally nothing else. I know it's a heavy program, so I separate it from other work so I can continue on while processes happen. 

All of a sudden, arcmap is just continually not responding to basic functions starting with joins. Something that used to take about 5 minutes now takes a couple of hours, but then freezes as soon as I try to export (or import the layer) or click any other place in the map document. 

I have already reset my profile and even reinstalled the system, so this is something weird b/c again, I was in it and doing this work just a week ago. 

Can anyone help?! (also submitted a support ticket, but so far that hasn't produced anything helpful so welcome suggestions) 

0 Kudos
3 Replies
Occasional Contributor III

Hey Evaine Sing‌,

Can you tell us a bit about the data you are trying to join? How many features in each? What are your join parameters?

Have you watched your computers task manager while running the join to see if it is maxing out your computers memory?

What are the specs on the PC?



If this answer was helpful please mark it as helpful. If this answer solved your question please mark it as the answer to help others who have the same question.

New Contributor

Hi Ben,

Here’s the specs from the “Can you run it” tool that ESRI sent. I know it’s not the best comp, but should be more than enough.

Also, update: I sent my data to a friend who has a much newer/better/faster machine and is doing his Master’s in this and he ALSO could not run the basic operations, so there is something bigger wrong here.

Starting with a county parcel boundary shapefile and trying to save out new layers by individually joining data to it for a total of 5 new shapefiles. The weird thing is that the data is coming from 3 separate - all reliable and previously used sources in familiar formats - and NONE of them will work. The largest join is a 1-1 match of assessment data to the parcels, but I have never had an issue with that before (and I do this at least 2x/year) but also, sales transactions, USPS vacant properties and those without buildings on them - all would narrow down the 500,000+ parcel file to somewhere between 29k and 120k depending on the dataset. Again, not small, but not uncommon.

Weird thing is that 2 weeks ago, I did the assessment join with a public file that worked fine, but as it doesn’t have ownership data, I went and purchased a CD from the Real Estate department - so the EXACT same file, but with owners in it now, and it will not work for the life of me. Sadly, I went back to try to do a clean join with the no owner file and it now will not work either. I already have that one saved from 2 weeks ago, but I do not have any clue what’s happening here…

Evaine K. Sing, RLA, LEED AP

EKS Solutions LLC <> | Community & Organizational Consultant

e: | c: 412.605.7465

WBE | WOSB Certified

0 Kudos
MVP Emeritus

Start by bring your files into a file geodatabase rather than shapefiles and try the joins using those.

0 Kudos