Address Locator (Street Name) Not Working

952
3
02-04-2018 07:08 AM
JacobHorwitz1
New Contributor II

I've created an address locator for only just street names (no numbers and line shape). However, when using the geocoding tools in ArcGIS(5.1), the tools would that the address is not found. I typed the street name in the correct spelling, but is not showing up for some reason. Is there something I'm missing for an address locator with just only in street name form?

Also: When I did this for single house locator(points) it works just fine.

0 Kudos
3 Replies
JoeBorgione
MVP Esteemed Contributor

Did you mean 10.5.1?  What style of locator is is 'failing'?  I can only speculate that you tried a dual range style or one that must have some sort of range to function.  I will also speculate that if you are trying to match against street segments in which many share the same name, you are simply mis-using that type of locator.

I'll also suggest that the reason your point locator works is because you have one point with a street name as 'S MAIN ST" and another with the them "N ELM AVE" etc etc.  That way, if you have several addresses on S Main ST they all match to that one location; same is true for any addresses on N Elm Ave.  A question I have is what do you plan to do with your results?  The basic premise of geocoding is to turn an address that you and I recognize (1234 S Main ST) into an XY location the GIS recognizes.  If you are 'stacking' mulitple addresses on one point, you may not be doing yourself any favors with respect to spatial distribution.

can't wait to retire....
JacobHorwitz1
New Contributor II

I was able to get it working again somehow. I probably didn't set the address locator to Street Name as that was the Address Locator style. This locator would only be used as part of a demo web application for future projects.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

You might want to mark you question close then Jacob

0 Kudos