Couldn't open project..??

1989
13
10-12-2016 04:50 AM
Highlighted
New Contributor III

Hi.

I am using newest Android beta version of workforce. When I try to open project from mobile I get an error: Couldn't open project..??

Reply
0 Kudos
13 Replies
Highlighted
Regular Contributor II

Hello Timo, there's a few reasons why this error may appear, can I ask if you can supply a copy of the error so I can confirm the message?

thanks, Craig

Reply
0 Kudos
Highlighted
New Contributor III

Hi

I took a screenshot of the error. There is no more information in it...

Do you need more information or do I have to share the project?

Timo

Reply
0 Kudos
Highlighted
Regular Contributor II

Hi Timo,

Ok, at this point, I think the best way to approach this is to take a look at the project.

Can you invite me to your organization and share the group with me?

thanks,

Reply
0 Kudos
Highlighted
New Contributor III

Invitation sent...

Reply
0 Kudos
Highlighted
Regular Contributor II

Sum of the offline discussion on this issue.  The named user was a Dispatcher and not a Worker in the project being opened using Workforce (Android) mobile.  Dispatchers do not have access to the project through the mobile app.

Once Timo added the user as a Worker to the project, the Worker was able to open the project.

We'll be improving the message displayed to the user when they attempt to open a project to which they do not have the proper permissions.

Craig

Highlighted
New Contributor

Hi Craig, 

I have the same issue as Timo. I am trying to make the Workforce for ArcGIS app work on an Android phone and tablet. The workers are able to log in with their usernames and see the project. However, when they try to open the project they get the error: Couldn't open project. The users are Mobile workers and not a Dispatcher. They are also part of the group where the project is stored within the ArcGIS Online environment. 

When I try the same workflow on an iPhone or iPad it works fine. 

Can you please help me with this issue as all our workers work with an Android-based device...

Thanks,

Cecile 

Reply
0 Kudos
Highlighted
Regular Contributor II

Hi Cecile,

Which Beta of Workforce on Android are you using?

Can you add my named user to the project as a worker so I can take a look?  You can do this by unchecking "Only search for users in my organization." on the Users tab.

Craig

Reply
0 Kudos
Highlighted
New Contributor

Hi Craig, 

We use the Workforce for ArcGIS beta version 0.2.1 (build 1483) on an Android phone which has an Android version 6.0.1. I will add you to the project. 

Thank you for your effort!

Cecile

Reply
0 Kudos
Highlighted
Regular Contributor II

Hi Cecile,

I can reproduce the issue using 0.2.1 Beta.  I can also confirm that it is fixed in our recent builds; I'm working on identifying what has changed.

Craig

Reply
0 Kudos