Invalid raster dataset. Failed to create raster layer. Permission Denied. How can I overcome this problem?

11505
17
10-25-2018 09:45 AM
CaioMansini
New Contributor II

Hello everyone,

I'm having this issue with my ArcMap 10.6.1. I think it is probably a "permission" issue, because I cannot copy and paste files on ArcCatalog. How can I solve this? Any ideas?

Thanks in advance.

Tags (1)
0 Kudos
17 Replies
XiaomengZheng
Esri Contributor

Hi Caio,

Are you able to copy/paste other format data such as feature class or tables? If this only occurs to the raster, I would recommend you reaching out to Raster/Image Server and the issue might be related to the data you tried to copy.

Thanks,

Meggie

CaioMansini
New Contributor II

Hello Meggie,

No, In ArcCatalog I do not have permission to copy anything on ArcCatalog. My Professor suggested that this might be a problem of "access" and recommended me looking for solutions here. Any ideas on how to overcome this problem? Or how to change permission in ArcCatalog? Because the following message is always "Permission Denied".

Thanks in advance.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

I suspect the permissions are controlled by your organization.

Where are you trying to copy/save stuff too?  Normally students are given full access to a subset of your local machine but denied access to other folders to prevent system/image corruption.

0 Kudos
CaioMansini
New Contributor II

Hey Dan, thanks for replying!

I'm trying to move the raster dataset into ArcMap. The folders are in my desktop, but I still can't drag the rasters into ArcMap.

The Professor said that these files are old and do not have any permissions assigned. Any ideas on how to change that or how to find the folder that I have permission to drag?

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

try not dragging... we restrict such things in certain circumstances.  Add the data manually through your Add data option

0 Kudos
CaioMansini
New Contributor II

Same error

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

could you specify the file's name and file path.

All I see is a folder highlighted in the c:\users.... folder and it is a path with spaces in it and Unicode characters.

I would suggest trying to copy it to a folder with no spaces and really simple... maybe c:\temp ….

And does the file have a filename extension? ie a *.tif. or is it the afpop2010_18 file?  if it is that one, then it might be an esri grid... which totally doesn't like paths with spaces or filenames greater than 8 or 10 characters (long time since I used them.  If it is an esri grid then it is lacking an info folder.  So you will need to find out what kind of raster it is

CaioMansini
New Contributor II

Hi Dan,

Yes the file path is "C:\Users\caiom\OneDrive\Área de Trabalho\Assignment 3" (Do not mind the characters, I'm Brazilian, but my Windows is in English. However, for some reason the Directories are all in Portuguese and all other things in English).

I tried your suggestion and moved the files to the folder "C:\Temp\As3" and it worked. Is it an error related to the path name or is it because there is some issue about permissions in the TEMP folder? Because the OS allows anyone to access the temp folder without restrictions, this is a default config in Windows.

Thank you very much!

DanPatterson_Retired
MVP Esteemed Contributor

Glad it worked!  Pass it on. 

Don't use paths and/or filenames with spaces. 

They work sometimes to most of the time. 

They will never work when you really need them too .

We also don't allow our students to store files in the C:\users... folder for a variety of other reasons. 

We had IT set a specific folder (C:\Students) that students can make their own folders in and save their work. 

The machines are routinely 'wiped' and reimaged except for files in that folder.

Good luck