Reconcile and Post automatically in a workflow

3723
5
01-19-2012 10:34 AM
DiegoLlamas
Esri Contributor
Hi

I migrate from JTX 3.0.1 to WMX. In my workflow I create a AOI, I do QC, is there any way to reconcile, validate topology and post as costum steps in my workflow in WMX?

If any body knows would be awesome your help

Thanks
0 Kudos
5 Replies
AshleyMott
New Contributor III
I use the Reconcile Version GPTool (JTXDesktopSteps.LaunchGPTool) to accomplish a reconcile and post as one step in one of my workflows. I have the "post" parameter set to "true."
0 Kudos
DiegoLlamas
Esri Contributor
Thanks, and are you using topology? I thing a could have problems with the dirty area. So, you are saying that you have this gptool in a model an then you launch this model? if is so, do you have to use a parameter to write the Jobid?

Thanks

I use the Reconcile Version GPTool (JTXDesktopSteps.LaunchGPTool) to accomplish a reconcile and post as one step in one of my workflows. I have the "post" parameter set to "true."
0 Kudos
AshleyMott
New Contributor III
I use the Reconcile Version GP Tool (with post argument enabled) as one step in a WMX workflow. Earlier in the workflow, I have a .mxd that launches with a Task Assistant workflow that has some steps that walks the user through topology. This TAM workflow is only semi-automated and relies on the user to know what to do.

I am not sure how to check topology automatically. I do, however, have a great tool that I use from the Data Reviewer extension that compares versions, so I compare each change in the user version to default. Data Reviewer also can check for some topology errors. This extension can be a bear, but the compare versions functionallity makes it worth it.
0 Kudos
AlisonGaiser
Occasional Contributor
Just wondering if you could share some further information about how you implemented this? I am having problems with the in_workspace parameter of this GP Tool. My in_workspace is an SDE database and we have created a standard connection on all user's machines. When I create the step I populatde the in_workspace parameter with Database Connections\RdsDev_RecAndPost.sde. This is the name of the Database Connection available on each user's machine. Unfortunately, when the user runs this step they always get a red x next to the Input Wokspace. I realize that all they need to do is navigate to this location, but my client wants them to just hit OK and have the step run.

Any thoughts?

Thanks,
     Alison
0 Kudos
ChelseaDuncan1
New Contributor II

I am experiencing the same issue where the launch gp tool launches with the invalid input workspace. Did you ever find a resolution for this issue apart from manually navigating to the location?

0 Kudos