Why can I not edit feature service geometry in AGOL web mapping application

01-09-2019 12:07 PM
Occasional Contributor II

I published a hosted feature service layer. I'm the admin on our AGOL account. I made a web map using my point layer (editing works in map). I created a web app using my map. The app, map, and feature layer are all shared with my group that I also created. Feature layer editing is turned on. 

Within the web app, I cannot edit features. I tried "Smart Editor" widget and it says no layers are available to edit. I tried "Edit" widget, and it tells me my account does not have permissions to modify data. Is there another widget for moving points around? 

I saw in other blogs to try things like clearing filters and resetting symbology to just basic locations (annoying that would break it), and I tried that in my map and it still does not work in the app. I also verified there are no Z values on this layer. The whole purpose of this app is to move points around. This should be very simple, except its not.

0 Kudos
0 Replies