Web map not defaulting to initial extent

2974
5
02-11-2016 12:52 PM
Clarson
New Contributor III

I built a webmap in ArcGISonline using ESRI's webappbuilder and deployed it to my organizations web server, here.

Everything seems to be working except for one thing. If I refresh the map or go browse somewhere else on the internet and come back to the web map URL is doesn't default, or reset, the initial extent of the web map (which was configured to in the webappbuilder on arcgis online). the map remains focused wherever I left off even after a refresh.

How can I fix this? Any help would be greatly appreciated.

0 Kudos
5 Replies
BarnabyRockwell
Regular Contributor

As far as I know, the only way to reset the extent is to click the Home button (at upper left in foldable theme).  Now if there was only a way to also reset all the layer visibility settings as well!!!!!! 

MichaelMiller2
Regular Contributor

See the thread below, it's been covered many time in recent months.

https://community.esri.com/thread/168685

DerekLaw
Community Moderator

Hi Clement,

Just to add onto Michael's post, this is a known issue and we are working to resolve/fix this in the next ArcGIS Online update. Sorry for the inconvenience.

Hope this helps,

DerekLaw
Community Moderator

Hi Clement,

FYI, in the forthcoming ArcGIS Online March 2016 update, the embedded Web AppBuilder for ArcGIS will have the "save app state" functionality be optional. As the web app author, you will be able to enable/disable this capability.

Hope this helps,

AndrewValenski
New Contributor II

Clement,

As Derek pointed out this functionality will be available in the forthcoming release in March 2016 of Web AppBuilder. For a more robust discussion of the changes coming with the release, check out this site:

What’s New in Web AppBuilder for ArcGIS (March 2016) | ArcGIS Blog

Thanks!

Cheers,

- Andrew