Web AppBuilder Smart Editor - Can't move point

1401
8
09-22-2017 11:19 AM
JamesSamek
Occasional Contributor

When trying to edit the geometry of an existing point, it can't be moved. When I create a new feature, I can move the point, but once I save, I can no longer move it.

Any thoughts?

Tags (1)
8 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

James,

 

are you the author of this feature service? When you go to the rest endpoint what are the allowed capabilities for the service

 

i.e. Capabilities: Create,Delete,Query,Update,Uploads,Editing

JamesSamek
Occasional Contributor

It is a feature service from AGS with the data in an enterprise geodatabase. The endpoint has the following capabilities:

I can edit the attribute data without issue. I can edit polyline and polygon geometry without issue. I just cannot update a point geometry. When I check the box to "Edit Geometry" and hover over the selected feature, the cursor does not change to a pointer from the arrow as it is supposed to. Perhaps this is a smart editor widget issue?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

James,

   What version of WAB are you using?

0 Kudos
JamesSamek
Occasional Contributor

WAB 2.5 and also AGOL. Both have the same issue with the widget.

0 Kudos
JamesSamek
Occasional Contributor

Update: It works in WAB 2.4 - so it is an issue with 2.5 (and AGOL)

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

I would call esri tech support to confirm this is a known bug.

0 Kudos
FrankVignati
Occasional Contributor II

This has been an issue: https://community.esri.com/thread/170820 

If you set the symbology to Location Only and use a standard ArcGIS Online symbol it works better

0 Kudos
KeithGerhartz1
Occasional Contributor II

This behavior will occur if there is another layer on top of the point layer. Not sure if this is the cause in your case.