Web AppBuilder - get "Failed to create the app." error on creating new app

4948
6
01-12-2016 11:40 AM
DanSlayback1
New Contributor III

I've just setup a fresh install of Web AppBuilder (1.3) on a linux workstation (Ubuntu 14.04). I'm able to connect to the host's 3344 port with Chrome (version 47.0.2526.106 (64-bit)), and start Web AppBuilder, and then connect to an ArcGIS Portal account (different machine). This all appears to work fine.

But when I click on the "Create New" button, select default (or any other template - same result), fill in a title and description, then click OK, I get a pop-up window saying "Failed to create the app.". 

The console window where I launched "node server.js" shows no information from this event.

If I open Chrome's developer tools, it reports various syntax errors under the console tab - see attached. not sure how to interpret these...

I tried to do this using firefox, in case it was an issue with Chrome, but Firefox seems unable to even connect to the portal URL. Instead, on the initial page, it says "Unable to access https://<myportalurl>:7443/arcgis". Despite that very same URL working in Chrome. I've restarted node, but no matter. Perhaps that is a separate issue...or not...

node.js should have a sufficient version -- according to the docs, 0.10.0 required, and "node --version" reports 0.10.25 installed.

Any ideas or suggestions where to look for clues?

Tags (1)
0 Kudos
6 Replies
AaronDorsey1
New Contributor III

Did you find a solution to this?

0 Kudos
DanSlayback1
New Contributor III

I have resolved it, but there were a couple of different issues, and I'm not exactly sure which caused this specific problem (I was trying to run Web AppBuilder with 3 different Portals, all of which were slightly different in configuration etc).  Things that helped were:

1. Use the actual/full Portal hostname (possibly with port 7443) when setting the Portal in the initial Web App Builder screen . I had been using a cname for the hostname, which is also the URL the Portal was configured to use. This seemed to solve the "Failed to create the app" problem.

2. Check your web App information (on the Portal machine), and update the redirect URI's to include all variations of http and https, for BOTH the client machine (that is running Web App Builder/node.js), and the Portal machine, including both its actual hostname, and any cnames (if you have any setup). Perhaps some smaller subset of all these variations would work; I've not tried to isolate exactly which. (So I have 6: http/https for client machine, and for the full Portal hostname, and for the Portal cname).

3. Check your tomcat install on the Portal machine. In one case, the Portal machine is running CentOS 5.11, and originally had to install tomcat7 outside of the normal package management tools (as its not available for 5.11). That original tomcat7 install had not been updated in 2 years, and although it appeared to be working (normal Portal access worked fine), I uninstalled/reinstalled web adaptor, and then was unable to get to the configuration page for web adaptor, until we upgraded tomcat7 to the latest version (7.0.67). Then everything worked fine for WAB with that Portal.

4. I was also told by ESRI support that I can (and possibly should) have separate web adaptors setup for both ArcGIS Server AND ArcGIS Portal (in our case, both are on the same machine). In the end, that was not necessary, but trying to get two configured helped find the problem with the tomcat7 version.  But you may want to try setting up two web adaptors (one for portal,one for server), if you're still stuck.

MichaelKelly
Occasional Contributor III

This can also be caused by your antivirus software blocking the creation of files/folders in the server\apps folder - you may need to add an exception for this.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

All,

   This turned out to be a Tingo DB record creation issue and can be overcome by ignoring the creation error and continue to click the OK button (could be 10 or more times) until it finally lets you create a new app and then from that point your WAB should be fine creating new apps.

JeffPace
MVP Regular Contributor

I am having this problem after updating from 10.5 to 10.5.1. I also cannot use the edit widget in previous configured apps based on a template (although it works fine in config, just not after launching). Can not create any new wab apps.

Any ideas? When i click ok, the window goes away, i can not click it again

0 Kudos
MattFoster
New Contributor

Hey all, We have an offline ArcGIS server and found the issue was caused because we didn't have a basemap set under the: Organisation Settings - Map - Default Basemap.

I figured this out after we were about to build 3D web apps and not 2D web apps.

Hope it's useful a few years on!