Web AppBuilder Developer Edition - Can't create new Apps

8079
20
10-06-2015 01:56 PM
KieranO_Donnell2
New Contributor II

Hi all,

I've been using Web AppBuilder Developer Edition (1.2) since its release and have just run into a new error

I am unable to create any new Apps, as a blank box (like an error message would) appears with only the option to click Ok.
See screenshot below.


I have made a number of new apps with this latest Developer Edition of Web AppBuilder, and am still able to edit the existing apps.
This issue has only recently sprung up, and is seemingly random as nothing should have changed to create the problem.

Has anyone else experienced this problem?

Cheers,
Kieran

20 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Kieran,

   Can you check your browsers web console and tell us what error details are listed there?

0 Kudos
albavoli
New Contributor III

happen the same to me what is the problem

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Kieran/Alba - how many is "a number of new apps"?  Maybe they is a limit in WAB?  (one I haven't hit yet).  I'm more curious about right now myself.  Or maybe a practical or physical limit of the machine?

A workaround might be to create a new instance of WAB (i.e., unzip the WAB download to a new folder and start a new version). Then "download" one of you developed apps and import it into the new version as a starting point (if it's the same version, you should be able to copy the folder over instead I think).  The problem of course with that is I think you will have to move all your custom widgets over again for any new apps (or copy over the folders in the <WAB>\client\stemapp folders.    I haven't tried this, but that is what I would try.

KieranO_Donnell2
New Contributor II

Thanks Rebecca,

It does not seem to be the number of apps, as I have tried deleting a few, but there's no change.

This workaround seems to have worked. The problem happens intermittently though so hopefully it does not return.

Cheers

MichaelRobb
Regular Contributor II

A much easier workaround is to simply Create a BASIC VIEWER.. it will run.  Then you will be able to create DEFAULT again without issue.

KieranO_Donnell2
New Contributor II

Hi Robert, I can't see any errors

0 Kudos
KAnderson
New Contributor II

I had this same problem! I also couldn't duplicate an existing app.

I ended up doing what Rebecca suggested: downloaded all my map apps, archived the existing "arcgis-web-appbuilder-1.2" folder, re-installing, copied over the widgets from before, and then imported the zipped maps I was still working on.

It is a weird issue - for the first couple of days I had this problem, I could clear the cache, switch browsers, and/or restart the computer to get WAB back to running, but then all those options stopped working.

JunshanLiu
Occasional Contributor III

It looks strange, could you post your server log, browser console log, browser network log? Thanks!

NathanielRoth1
New Contributor III

Any resolution to this? It's happening to me too.

I have both 1.1 and 1.2 installed, and they happily cohabitated since I installed 1.2 up until a short while ago, then 1.2 stopped letting me create new apps. 1.1 still works fine.

Using Chrome v46.0.2490.80m

When the empty message box is open, there is nothing except a XMLHttpRequest event deprecation notice.

Network log:

templatelist?portalUrl=http://cadoc.maps.arcgis.com200xhrinit.js:152736 B55 ms
flag_2d.png200pnginit.js:1281.9 KB17 ms
thumbnail.png200pnginit.js:1283.9 KB20 ms
thumbnail.png200pnginit.js:1284.6 KB23 ms
thumbnail.png200pnginit.js:1283.9 KB18 ms
flag_3d.png200pnginit.js:1281.9 KB23 ms
comingsoon.png200pnginit.js:1289.3 KB11 ms
thumbnail.png200pnginit.js:1283.9 KB10 ms
self?f=json&token=Vwo5SGOH84cdc_TL9OkTFvuF80hZ2_jcFjiNl9eAJuI5yeGIWRkv2vjgHslS6QBIDuFncbsd2QSX5q_f86T58B6g4UjFvKvR0vp7V77ivNtxx4E557qzocGv6dvWG8GseW5oFO81p4_JJs1N3YVy-Hb7fpCGHz5IEPltbPxh8dhV6Bj1SIQ33EElyfqAbMCm&dojo.preventCache=1446045945389200xhrinit.js:1524.5 KB199 ms
self?f=json&token=Vwo5SGOH84cdc_TL9OkTFvuF80hZ2_jcFjiNl9eAJuI5yeGIWRkv2vjgHslS6QBIDuFncbsd2QSX5q_f86T58B6g4UjFvKvR0vp7V77ivNtxx4E557qzocGv6dvWG8GseW5oFO81p4_JJs1N3YVy-Hb7fpCGHz5IEPltbPxh8dhV6Bj1SIQ33EElyfqAbMCm&dojo.preventCache=1446045945393200xhrinit.js:1524.5 KB202 ms
getsignininfo?portalUrl=http%3A%2F%2Fcadoc.maps.arcgis.com200xhrinit.js:152372 B4 ms
loading.gif200gifOther970 B3 ms
groups?f=json&q=title%3A%22ArcGIS%20Online%20Basemaps%22%20AND%20owner%3Aesri_en&token=Vwo5SGOH84cdc_TL9OkTFvuF80hZ2_jcFjiNl9eAJuI5yeGIWRkv2vjgHslS6QBIDuFncbsd2QSX5q_f86T58B6g4UjFvKvR0vp7V77ivNtxx4E557qzocGv6dvWG8GseW5oFO81p4_JJs1N3YVy-Hb7fpCGHz5IEPltbPxh8dhV6Bj1SIQ33EElyfqAbMCm200xhrinit.js:152892 B102 ms
search200xhrinit.js:1521.6 KB5.73 s
createapp200xhrinit.js:152300 B12 ms

Server Log:

[2015-10-28 08:19:01.686] [INFO] repo - Read repository items: C:\arcgis-web-appbuilder-1.2\client\stemapp\widgets

[2015-10-28 08:19:04.010] [INFO] repo - Read repository items: C:\arcgis-web-appbuilder-1.2\client\stemapp\themes

[2015-10-28 08:19:04.980] [INFO] server - Set isXT = true;

0 Kudos