Web AppBuilder - Date filter in Filter widget default options don't automatically apply

199
1
10-07-2021 11:14 AM
Labels (1)
AbigailStephens
New Contributor III

It was recently brought to our attention that the default date options in a date Filter widget aren't automatically applying.

To elaborate, we have many maps with a Filter widget added. To prevent confusion for non-GIS savvy users, we generally set these filters to be automatically on, so when they change any available filter options, the filter is automatically applied. For most of these filters, they have several possible queries based on several fields, that ask users for values before filtering.

For date fields, we usually use the "between" option, and noticed recently that the default options of "Yesterday", "Today", and "Tomorrow" don't seem to apply automatically. For example, if you set the range to 10/1/21 to "Today", nothing happens, but if you change the range to 10/1/21 to 10/7/21, the data automatically filters.

We also noticed that if you turn the whole filter off and back on, the "Yesterday", "Today", and "Tomorrow" options do apply, it only doesn't work when the filter is on before the date range is set.

Has anyone else seen behavior like this? Is this expected behavior? Is there anything we can do to fix it?

We are running ArcGIS Enterprise 10.7.1 on Linux.

0 Kudos
1 Reply
shaylavi
Esri Contributor

I've seen this before. I changed it as I was working on the dev' edition and customizing that widget

Shay
0 Kudos