Web AppBuilder attribute table not working properly with filter applied

108
0
04-27-2020 09:29 AM
Bianca
by
New Contributor II

When applying a filter through the attribute table, certain features no longer work properly. If I double click on a row to zoom in, it doesn't work. I also tried selecting the row and then clicking on "Zoom to" but it still doesn't work. Interestingly, even with the row selected and highlighted, the bottom of the attribute table still says there are zero features selected, and no features are highlighted within the map. Without a filter applied, it works properly and I can zoom into a selected feature (and at the bottom of the table it says 1 selected).

Additionally, if a filter is applied it will say for example "30 features" at the bottom of the attribute table but only show 25 rows. If I scroll to the top, click on a column and select sort ascending or descending, then all 30 records will show. But once I scroll through again, and then scroll back to the top, it has removed the top 5 from the table view unless I sort again. I believe this is working properly without the filter applied, though the dataset contains 3400 records so I have not counted all rows. But the same records appear at the top and bottom of the table after scrolling through, so I assume it hasn't removed any of them from the table.

Any idea why these issues could be occurring, particularly only when I apply a filter?

0 Kudos
0 Replies