Web App Query Widget- Zoom Issue

509
3
07-06-2017 09:27 PM
Alana_Corney
New Contributor

Very similar to this thread - https://community.esri.com/thread/160676 but the solution hasn't worked for me.

I've developed a Web App using the Web App Builder in Portal (I believe 10.4) . The app displays a point Map Service from the federated server. I am having an issue with the results of a query using the built-in Query widget.

 

Once I run a query (which pulls back over 200 results that are spread throughout the world), the results window displays properly, but the map does not display (just a gray screen). Also, the scale bar shows “NaNmi” instead of the normal scale bar notation. I cannot zoom in or out and the only way I can fix this is through the home button.

I have removed all of the NULL lat longs that were in my dataset, but my data is spread far and wide around New Zealand from 40 to -70 latitude and crosses the 180° meridian (so I have data in positive longitudes: 176.5, 165.9 etc and in negatives once it crosses:  -179.5, -165.9 etc)

I assume this is an extent issue as the other thread solved their issue by removing the 0,0 coordinates, but my data is legitimate and I need a way to be query data that is spread over a wide distance without the screen crashing and going grey.

Any help would be appreciated!

Cheers,

Alana 

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Alana,

   Is your data public (so that I can test this)? Are you sure that you have remove all erroneous lat and lon values from your data? 

0 Kudos
Alana_Corney
New Contributor

Hey Robert,

Unfortuntely the data isn't public, and I'm in Systest so I can't share it...

I've put on a definition query to remove all NULL lat and long records so they should all be out of the dataset.

Cheers,

Alana

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Alana,

   Sorry I am not sure what to tell you then.

0 Kudos