Web App editor hangs on web map created in ArcGIS Pro, unless I resave

170
5
01-14-2022 09:24 AM
Labels (1)
JohnSasso
New Contributor II

In ArcGIS Pro, I modified I map so I could group multiple layers, then shared the map.  When I bring up the map in the new Map Viewer in ArcGIS Online and simply do a Save (without any mods to it in Map Viewer), I get a red-bordered dialog box at the bottom that says "Error:  There was an error."  No other info.  Analyze in ArcGIS Pro only produced "24125: Service layer's item ID will not be included" which I read is innocuous. 

Furthermore, if I try to use the map in my web app (in Web AppBuilder), WAB hangs on it, no matter how long I wait.

The only way I can save the map is if I am in MapViewer Classic, do Save of it in there, and then I am also able to load the map in WAB!   Unfortunately, I lose the grouping of layers.

I gather WAB hanging on the map may be due to "Error:  There was an error" but if I knew what the error was, I'd be able to resolve!

 

0 Kudos
5 Replies
AdrianWelsh
MVP Notable Contributor

John,

That is frustrating! My assumption is that WAB only uses the classic map viewer, not the "new", so when the map is saved in the new map viewer with grouped layers, it isn't fully compatible with the 'antiquated' WAB. So it seems to be a compatibility issue. I am not as familiar with experience builder as I am with WAB but maybe ArcGIS Experience Builder can support the "new map viewer" and allow the same functionality with group layers and hopefully similar widgets as to what you were using in WAB?

0 Kudos
JohnSasso
New Contributor II

Well, for reasons unknown to me, sharing the map from ArcGIS Pro does "something" to the map such then when I attempt to include it in my web app in Web AppBuilder, it hangs.  What that "something" is I do not know.  As noted, I have to bring the map into MapViewer Classic and just do a Save on it to eliminate the hang.   

On a general note, I wish Esri had not pushed out the new MapViewer until it was full compatible with MapViewer Classic.  Because of this and other issues I have encountered, I have deemed the new MapViewer basically useless.  

0 Kudos
HelenCooper
Occasional Contributor III
I’m afraid WAB builder can’t handle grouped layers. You’ll need to use experience builder for that (although that comes with drawbacks as you can’t achieve everything you can in WAB…)
0 Kudos
JohnSasso
New Contributor II

Thank you for the clarification, Helen!  I looked at Experience Builder FAQ and it seems to me it is nowhere near up to snuff w/r/t Web AppBuilder.  Again, another frustration I have with Esri in that they are pushing out products that, to me, are not ready for prime time.

I am using Web Appbuilder to make use of widgets and other features.  Since it appears the only way I can implement groups layers is in ArcGIS Pro, it seems I cannot do so 😞

0 Kudos
HelenCooper
Occasional Contributor III

Yes, I ran into the same frustration a couple of months ago.  All of the nice new functionality in the new map viewer (grouped layers and more advanced symbology, etc) can’t be used in WAB.   I understand that WAB uses the 3.X version of the JS API, and the new map builder 4.X.

I tried using EB instead but lost some of the fundamental functionality I was using in WAB, so reverted back to that… 

Agree that products are being pushed out before they should be, which is a shame, as there is a lot of great functionality in the ‘nearly ready’ pile!

0 Kudos