web app builder developer application once deployed and added as An Application, what is the best way to update?

1525
23
Jump to solution
01-29-2018 01:27 PM
PhilBeilin1
Occasional Contributor

I created an application using Web AppBuilder Developer's Edition. The app was deployed onto the companies web server (SDE) and then added to AGOL using the Create + -> An Application.

What is the best way to update the application in the future? I will be leaving this application behind and want to know the best workflow to leave in my documentation for the people responsible for updating it. 

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Phil,

  In that case then all the updates to the apps configuration will happen manually (directly editing the json files) on the web server. The other option is for them to have WAB Dev and import the app to make changes.

View solution in original post

23 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Phil,

   They would have to use AGOL Assistant to update any configuration files.

0 Kudos
PhilBeilin1
Occasional Contributor

Could you elaborate more on this? 
When I bring it up I can only find options to edit the Description Page.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Phil,

   When you login to AGOL Assistant you have the "I want to...", choose "View an item's JSON", then find the WAB app in the right pane and select it, in the left pane scroll down to the data section (it is right under the description pane). There you will find the apps main config.json that you can click on the edit button in this panes header and now you can edit the json and save your changes.

PhilBeilin1
Occasional Contributor

There is nothing under the description pane for me.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Can you make sure you are logged in as an administrator for the AGOL site?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

So you are sure you are choosing your WAB app and not some other item named similarly?

0 Kudos
PhilBeilin1
Occasional Contributor

This is it. It's not there and I'm assuming that the app has to be registered first. 

As for registering the application, it is on one of our servers, will this change how create the URI's of the application?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Phil,

   OK let me go back an review your original post (because I made some assumptions).

The app was deployed onto the companies web server (SDE) and then added to AGOL using the Create + -> An Application.

Correct me if any of the steps below are not correct.

  1. So you created a WAB Application using WAB Dev.
  2. You then exported the app so that you had a zip file of the app
  3. You extracted that zipped app to a web server "The app was deployed onto the companies web server (SDE)" Not sure why you say SDE unless the SDE server is also the web server.
  4. You then took that url for the app and added it to the companies AGOL content  using Add Item?.. You said Create > App...?

0 Kudos
PhilBeilin1
Occasional Contributor

That is all correct, except I made a mistake - it's not SDE, but an ArcGIS Server. 

0 Kudos