WABD and Proxies?

917
8
Jump to solution
03-20-2017 04:40 PM
ShannonDeArmond
New Contributor III

I built an app in Web AppBuilder for Developers and deployed it on my server to which other folks on my intranet have access.
- The app is set in Portal to be shared with everyone in my organization.
- The app includes a handful of fairly standard custom widgets I downloaded, none of which consume credits in any way.
- The web map that the app is using is set to be shared with everyone in my organization.
- The map services inside the web map are set to be shared with everyone in my organization.

Folks in my organization can access the web map without logging into Portal, but if they attempt to access my new fancy web app, they are being asked for a Portal log in. What am I missing? I have not configured a proxy. I didn't think I needed one if the services were shared with everyone and I wasn't consuming ArcGIS Online credits. Is that correct?

0 Kudos
1 Solution

Accepted Solutions
ShannonDeArmond
New Contributor III

Alright, in the end, here is what ended up working. I realized I was using a slightly older version of web appbuilder developers edition, so I downloaded the current 2.3 release, imported my old app, redeployed it on my server exactly the same way as before, and like magic the portal login requirement disappeared. I had to reconfigure a handful of my widgets, but so be it. Thanks to everyone for your help.

View solution in original post

8 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Shannon,

  You are correct, if your web map and all the services in the web map are all shared publicly then you should not be getting a login popup. I would suggest you create another very simple vanilla WAB app and add a web map that only has esri base map and deploy that and test access to it (for testing your issue). If that works then add one of your web maps with one of your map services and repeat.

ShawnBowers
New Contributor III

In Portal, do you have the option checked to allow anonymous access to your portal under Security?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Anonymous access is not necessary. I do not have anonymous access checked and yet have not problems like Shannon is having.

0 Kudos
ShawnBowers
New Contributor III

Robert, do you share your maps and apps with "Everyone" or "Organization"?  Since Shannon is sharing just to the Organization the issue is that the web app can't verify that a user is part of the Organization so it asks for credentials.  If your Portal installation is behind the corporate firewall you can share the map and services with "Everyone" and that should do it.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Shawn,

   You may be correct then. I did not read her comment as meaning that she only chose to share the web map and services with the "Organization" (though that is exactly how she wrote it). I have my data shared with "everyone" when I don't require security for the data.

0 Kudos
ShannonDeArmond
New Contributor III

Poorly clarified on my part. The services, map, and app are all marked as shared with "Everyone".

0 Kudos
ShannonDeArmond
New Contributor III

I verified anyway and my "Allow Anonymous Access" box is checked. I'll try your troubleshooting suggestion above with the simple vanilla app and let you know how far I get. I appreciate everybody's help so far.

0 Kudos
ShannonDeArmond
New Contributor III

Alright, in the end, here is what ended up working. I realized I was using a slightly older version of web appbuilder developers edition, so I downloaded the current 2.3 release, imported my old app, redeployed it on my server exactly the same way as before, and like magic the portal login requirement disappeared. I had to reconfigure a handful of my widgets, but so be it. Thanks to everyone for your help.