WAB Near Me widget error/issue

1319
1
01-25-2017 03:13 PM
Chris_Robinson_COF
New Contributor III
Hello All,
I recently upgrade my developer edition of Web App Builder to version 2.3.  I then upgraded an app that I had built in WAB version
2.1 and have noticed an issue with the Near Me widget and its results.  I will attach a word document with some more detail and
screen shots but here is the issue I am having.
After upgrading this application from version 2.1 to 2.3 the near me widget will display an error of (Result(s) could not be found).
I have traced this to the option of having "Return Intersecting polygon(s)" turned on in the 2.3 version.  This was turned on in my 2.1
version and worked as expected.  When I turn this option off, save the map and launch, the near me tool works but it gives me
different results than I am expecting.  For instance I have a water districts polygon layer set up in my map.  When a selection is
made at my default buffer distance of 2 miles, I should at most get one to two returns depending on the area I click or address
that is chosen. The area I am testing I should only get one though I am for some reason getting 7 returns.  This can be seen in my
attached write up with screen shots.  When I then try to expand out the water districts, all I receive is a spinning wheel and the
result never expands. 
I thought it maybe had something to do with the map that is being used in both instances but after checking, they are using the
same web map from ArcGIS online.  Also of note, the my government services service is running on my internal ArcGIS server
that is running version 10.3.  I also tried this with the built in WAB on ArcGIS online and am getting the same results.
I can't think of anything else to check but wanted to get some input from the community, any help would be appreciated.
Thank you,
Chris
0 Kudos
1 Reply
Chris_Robinson_COF
New Contributor III

This turned out to be a bug

BUG-000102069 : The Near Me widget in Web AppBuilder does not honor the geocoding service configuration if it does not match the top listed geocoder in utility settings.

In my case I had a geocoding service from my ArcGIS Server instance locally as the top choice in our ArcGIS online organization.  The widget had the ESRI world locator as it's default so when the widget was activated instead of looking towards the world locator, it was looking for the default organization's.

Chris