WAB 2.7 Dev Edition have bugs or (behaving funny)?

333
2
02-01-2018 04:33 PM
James_001
Occasional Contributor II

Hi fellows,

I was trying to update my apps in WAB 2.7, it is not working quite well as it supposed to be.

I have tried by creating different new apps, update node.js , and download new sdk still I got different errors such as

  • Foldable theme and Jewelry box theme behave crazy,icon, widget disappears,slow response
  • Very slow  to save app in Launchpad theme and others too
  • Sometime everything disappear from WAB, It come back when after reload
  • WAB stuck while switching from one theme to another
  • Also, this is coming in Web appbuilder cmd every time and don't know what that mean is

express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1283
express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1433
express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1456
express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1505
express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1548
express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1590
express deprecated req.param(name): Use req.params, req.body, or req.query instead rest\signininfo.js:1:1630

I am not sure what should I do, although i never have problem in WAB 2.6. I will really appreciate any help!

0 Kudos
2 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Irfan,

   Yes WAB 2.7 has a few Bugs but none of these should stop you from using it (except maybe the first bug).

0 Kudos
James_001
Occasional Contributor II

Thanks Robert,

I was trying but some how it is not working well. I will stick with 2.6 until something new come up.  

0 Kudos